summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-02 13:53:13 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-02 17:43:43 +0200
commit715182afec8528d68a96b703393ac8b23621c178 (patch)
treef77c346f9d3c2c89a1211246140086d958a36cfa /app-text
parentdev-python/dataclasses: keyworded 0.7 for hppa, bug #737618 (diff)
downloadgentoo-715182afec8528d68a96b703393ac8b23621c178.tar.gz
gentoo-715182afec8528d68a96b703393ac8b23621c178.tar.bz2
gentoo-715182afec8528d68a96b703393ac8b23621c178.zip
app-text/poppler: Bump to version 20.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-20.10.0.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index c043ab287ab5..d0cb619887c2 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,2 +1,3 @@
DIST poppler-0.90.1.tar.xz 1633804 BLAKE2B 5c7256bca74af6cc2732fb6c413bec10ea579f28fe623ccb5d4863c62d39329a4264c240ee0e395a78de577a960a5156ba20f957990c0cde91efcee72dbc2fef SHA512 c0a38c3c40196f8b847f0737152d0cbb40656870a8ceb766134ee22ec7c21bc979a13f56b7596a13ae2f08f1a9a2c396ba7f5ff176d02c262af7e863c2afde34
DIST poppler-20.09.0.tar.xz 1642932 BLAKE2B be61275560bf57c639f185b5ebbd8b37b99fd008412f49890ed644e95f4d8f2c4ca865b081eea99f2604d44fa1c0c31bd551339340f03cb43ab7f5a03992f760 SHA512 fbd57dd0754279d4b0a20ccbdbfb06abc5a5d84e63915676353fd42d5b80318904cf7e6ae462db445ed6c6e011fc24675dccbb8bd3597fc6532657a4ea23406a
+DIST poppler-20.10.0.tar.xz 1644528 BLAKE2B ce38491805ff8ecb45eea45c44c93ec85404cb310ed6da49d7ce752a4e572abfbd7f5740448d6fb0c0958aa5661ebf87a3a2988bf51b0d0f0b1ea102110952b9 SHA512 edbcd53a06df9a5911a58fd05066e44dc8ab9a1dbc6da852b40bbc5627b9c0fcb35d97f46e3fcd78f7d08f86cba37e2ab3ff81b9a18fad300571df2bf1ef91a9
diff --git a/app-text/poppler/poppler-20.10.0.ebuild b/app-text/poppler/poppler-20.10.0.ebuild
new file mode 100644
index 000000000000..6d79d6797ded
--- /dev/null
+++ b/app-text/poppler/poppler-20.10.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 2005-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/103" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ introspection? ( dev-libs/gobject-introspection:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.60.1-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.82.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.61.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ -DENABLE_QT6=OFF
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}