summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-06-16 13:25:54 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-28 18:19:27 -0400
commit84a7ea3e93c926df24e5f82d8e2ff0c3acd54206 (patch)
treee4566cfe49c0082a7e0a49349a57a807a60d0937 /app-text
parentapp-text/hunspell: Patch CVE-2019-16707 (diff)
downloadgentoo-84a7ea3e93c926df24e5f82d8e2ff0c3acd54206.tar.gz
gentoo-84a7ea3e93c926df24e5f82d8e2ff0c3acd54206.tar.bz2
gentoo-84a7ea3e93c926df24e5f82d8e2ff0c3acd54206.zip
app-text/scdoc: version bump to 1.11.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/16271 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/scdoc/Manifest1
-rw-r--r--app-text/scdoc/scdoc-1.11.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/scdoc/Manifest b/app-text/scdoc/Manifest
index 4703e82d040c..6f23811e6c78 100644
--- a/app-text/scdoc/Manifest
+++ b/app-text/scdoc/Manifest
@@ -1,3 +1,4 @@
DIST scdoc-1.10.0.tar.gz 12414 BLAKE2B 3111b3ace102aca2f7da86e510e00f552874817b6b9d754770bd94f9482e4e444a4bc4d44a8317376a6c374bb7363eae96a49281fefd95dd663134087123034b SHA512 546743376380d84aa9c8be65529dbbe1634e574203220ce1c057341436bd3a15297f393ca79d29372cb125bf457cfc00f64ba2867b8d2e910ca6531acb552e97
DIST scdoc-1.10.1.tar.gz 12422 BLAKE2B 4aa5b28994cd03f5d3fc9fff253a02f1052653d25d41225665219ebb6322ebe69f2671d91c5cfe201fd7f9b1ac06f38db3dd126492da06fef0b692fc040300d5 SHA512 356aee85c4676a1fbd7367c6087dd7f6f4d33793be0f3fef74803ceb93c0a9e45c78022d219dc08a7d79d71c393849fa3113c36a85d5d60ed474b62bf5f89743
+DIST scdoc-1.11.0.tar.gz 12616 BLAKE2B 3aec60e51b949dc94e8339e400c366428a217c1bd44f79716cbd6993a7f8051a0796dc96163e071db4808c0edde071408e3eb1ee0ae3bb8ccd718479960ab8f3 SHA512 4c8248a12e69e53cc2182af5375912f7af64f3807163dbe3c52e85d817b1bfa7e461d02a627c73d93bdaa96e49668ff894d37817ceb70ee3186da9e3f8372d49
DIST scdoc-1.9.3.tar.gz 11479 BLAKE2B 79aa3f18104e06722f087e9c2fa047f6e19fe8eb47ba0b4e6fa86f7abdc52b06a2dfcfd632b16dc7bce6e5ef3b0dbb40ce9170e678bc17c0a4e43dcc0099a1dc SHA512 77be81f042e2099de7fc84b0161bc8a95d5c3dde662284613d84a1e249fa0aa51dad73f53f265c833526d40f5e1f19fce99dc5cd6df35efb0a323c3db6084a55
diff --git a/app-text/scdoc/scdoc-1.11.0.ebuild b/app-text/scdoc/scdoc-1.11.0.ebuild
new file mode 100644
index 000000000000..15ecbe1b112a
--- /dev/null
+++ b/app-text/scdoc/scdoc-1.11.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -e 's/-Werror//' \
+ -i Makefile || die 'Failed to patch Makefile'
+}
+
+src_compile() {
+ local MY_HS="./scdoc"
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ MY_HS="./hostscdoc"
+ emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
+ CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
+ mv scdoc hostscdoc || die 'Failed to rename host scdoc'
+ fi
+ emake LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
+ PCDIR="${ED}/usr/$(get_libdir)/pkgconfig" install
+}