summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-25 17:26:32 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-25 17:31:20 -0400
commit866c7c17834da734f7f1abf8fa366dc247bac059 (patch)
treef19730956f8c62d8255282cc65d0f5411ca995ac /app-text
parentnet-misc/libreswan: add systemd USE flag (diff)
downloadgentoo-866c7c17834da734f7f1abf8fa366dc247bac059.tar.gz
gentoo-866c7c17834da734f7f1abf8fa366dc247bac059.tar.bz2
gentoo-866c7c17834da734f7f1abf8fa366dc247bac059.zip
app-text/duali, app-dicts/duali-data: new revisions with EAPI=6.
These two packages needed simultaneous revisions to fix dictionary database compilation. The app-text/duali package provides a script (dict2db) that builds dictionary databases, and a module that uses them. Both use the "anydbm" python module, and should not care about the dbm backend, but the implementation details do -- they try to guess a filename, and each dbm backend outputs a different file name. In the new revision of duali, we require python[gdbm] to ensure that we get at least one of the file names that we expect. The new duali-data requires the new duali so that the databases get the correct name, and everything is happy. Minimal changes were needed for the duali-data ebuild, but the duali ebuild needed to be updated to use python-single-r1 and was rewritten. Gentoo-Bug: 380857 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text')
-rw-r--r--app-text/duali/duali-0.2.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/duali/duali-0.2.0-r1.ebuild b/app-text/duali/duali-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..a29db3f200a5
--- /dev/null
+++ b/app-text/duali/duali-0.2.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+# Duali uses "anydbm" which should even support a slow fallback;
+# however, due to implementation details it fails when the databases
+# aren't gdbm.
+PYTHON_REQ_USE="gdbm"
+
+inherit python-single-r1
+
+DESCRIPTION="Arabic dictionary based on the DICT protocol"
+HOMEPAGE="http://www.arabeyes.org/project.php?proj=Duali"
+SRC_URI="mirror://sourceforge/arabeyes/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+PDEPEND=">=app-dicts/duali-data-0.1b-r1"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang duali dict2db trans2arabic arabic2trans
+ python_doexe duali dict2db trans2arabic arabic2trans
+
+ insinto /etc
+ doins duali.conf
+
+ doman doc/man/*.1
+ dodoc README ChangeLog
+
+ python_domodule pyduali
+}