summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-19 18:33:18 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-19 18:34:15 +0100
commit8e5baccc5ad1a5ff5a29ac5e000f39419ef210ac (patch)
treef12a74a82928a2dfc12c254d8ce0c45831ea0d05 /app-text
parentdev-libs/libgit2: Remove old (diff)
downloadgentoo-8e5baccc5ad1a5ff5a29ac5e000f39419ef210ac.tar.gz
gentoo-8e5baccc5ad1a5ff5a29ac5e000f39419ef210ac.tar.bz2
gentoo-8e5baccc5ad1a5ff5a29ac5e000f39419ef210ac.zip
app-text/libwps: Version bump 0.4.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwps/Manifest1
-rw-r--r--app-text/libwps/libwps-0.4.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/libwps/Manifest b/app-text/libwps/Manifest
index b30e2ef81ef4..e674934800b2 100644
--- a/app-text/libwps/Manifest
+++ b/app-text/libwps/Manifest
@@ -1,2 +1,3 @@
DIST libwps-0.3.1.tar.xz 410376 SHA256 bb2c2a7db5121411ba705ccf3452cdce51d9798384fd9621e9702ba802878e93 SHA512 f628e6532b32331c7df0d97a9b71bf1f97347634657148b47d46ba7c2fd888d7fa9ffe52f31cfc24f86688c9c713bfaff360c7fe9f4a92d646cf8f21e7f5c2b1 WHIRLPOOL ebe35fabf22aedccfe3ca35e46971a26332040852357ea0f2241534261c77d597da38766192661ecd6fa24881e0bf9de4a80bdfea300129420d4635924434110
DIST libwps-0.4.4.tar.xz 574768 SHA256 b7c564bba7bc9058c524eaf94cb43448832aa03e3d763b98e11ee12d25082df4 SHA512 201b4a7d6788e4193aeff694e25bbda78678126b654907f4d20783afa343a069d7f6c12344b261496434df4fd1f3df933881a5ed5358f330cd15568c8710963d WHIRLPOOL de32feb8721771a5058b283b5dd6a59e005db1e53a8539c5e1268540cf3e9f5d0353babafcb42e82aade103dd1efc0834f0a80d7b3e995a8d5464ffbc0f538b7
+DIST libwps-0.4.5.tar.xz 588948 SHA256 8e175ab9339d447a285a1533bfdc405432b9a275e4f3a98690ffaf12fe7f4d4a SHA512 bed70efbd51bc18891e901810eba72e3b21050cde6ac170589cc0e55fb8cbef44de4be7b7ec657895715efaa30fb0ad1b6032cf507ca969d31cc03cc96973a94 WHIRLPOOL 91948ede9976c9d62865c76a93bc8779b14d9438dd5d64fd8f8d6fd98abe9bb748d19e0509c88b7f6d47770d5ce62c1e8ccb9a2281963166b4e93f465079a78c
diff --git a/app-text/libwps/libwps-0.4.5.ebuild b/app-text/libwps/libwps-0.4.5.ebuild
new file mode 100644
index 000000000000..673ff918b2aa
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+IUSE="doc debug static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --with-sharedptr=c++11 \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}