summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-09-01 10:17:16 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-09-01 10:17:16 +0700
commit8f57005559c5aa0c9596f9ded42186b7e82410f2 (patch)
tree5fbfcb8305459cd1e9c82ff5ead3987457758852 /app-text
parentmedia-sound/lilypond: version bump to 2.19.47 (diff)
downloadgentoo-8f57005559c5aa0c9596f9ded42186b7e82410f2.tar.gz
gentoo-8f57005559c5aa0c9596f9ded42186b7e82410f2.tar.bz2
gentoo-8f57005559c5aa0c9596f9ded42186b7e82410f2.zip
app-text/fbreader: make gcc6 happy
Bug: 592588 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text')
-rw-r--r--app-text/fbreader/fbreader-0.99.4-r2.ebuild2
-rw-r--r--app-text/fbreader/files/fbreader-0.99.4-gcc6.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/app-text/fbreader/fbreader-0.99.4-r2.ebuild b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
index 6d5c3102c10f..a05caff6483d 100644
--- a/app-text/fbreader/fbreader-0.99.4-r2.ebuild
+++ b/app-text/fbreader/fbreader-0.99.4-r2.ebuild
@@ -74,6 +74,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-mimetypes.patch
# bug #437262
epatch "${FILESDIR}"/${P}-ld-bfd.patch
+ # bug #592588
+ epatch "${FILESDIR}"/${P}-gcc6.patch
}
src_compile() {
diff --git a/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch b/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch
new file mode 100644
index 000000000000..c6f87a292697
--- /dev/null
+++ b/app-text/fbreader/files/fbreader-0.99.4-gcc6.patch
@@ -0,0 +1,11 @@
+--- fbreader/src/formats/doc/OleStorage.cpp 2012-11-30 13:41:25.000000000 +0100
++++ fbreader/src/formats/doc/OleStorage.cpp-new 2016-08-31 17:23:18.232536401 +0200
+@@ -59,7 +59,7 @@
+ clear();
+ return false;
+ }
+- static const char OLE_SIGN[] = {0xD0, 0xCF, 0x11, 0xE0, 0xA1, 0xB1, 0x1A, 0xE1, 0};
++ static const char OLE_SIGN[] = {(char)0xD0, (char)0xCF, (char)0x11, (char)0xE0, (char)0xA1, (char)0xB1, (char)0x1A, (char)0xE1, 0};
+ if (std::strncmp(oleBuf, OLE_SIGN, 8) != 0) {
+ clear();
+ return false;