summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-08 07:54:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-08 07:55:50 +0100
commita610634dabc452dba11d7833473efd01f54a5201 (patch)
treee99b56a0b0d68f09d4636f21a7ac0e670966b448 /app-text
parentdev-ruby/pygments_rb: add 1.2.1 (diff)
downloadgentoo-a610634dabc452dba11d7833473efd01f54a5201.tar.gz
gentoo-a610634dabc452dba11d7833473efd01f54a5201.tar.bz2
gentoo-a610634dabc452dba11d7833473efd01f54a5201.zip
app-text/qpdf: Bump to version 7.1.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-7.1.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 4bd67fdbf653..908dcae29a91 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -3,3 +3,4 @@ DIST qpdf-5.1.3.tar.gz 7681578 BLAKE2B f49762e7a92d0a638c998ab002bd3f83057fada59
DIST qpdf-6.0.0.tar.gz 8344860 BLAKE2B c041fd0a89dcce6275ccd51db62cc4fe37c2ee797d2d19c8924dc12f2a9166d7a918f220ed539045c81284544f061241f1783d6c25a0f63bed534fcef82370bc SHA512 303e3cc77ddb87b9494e26c35e0b45b42f73692054c56a00f2e4f1922633c6ebb45c8684992cd9bf32f03366fcc4cd7e7ec6fb9432d2dbba6e0b24395909b5bf
DIST qpdf-7.0.0.tar.gz 7053781 BLAKE2B 1abd54a3cdc24c3e56ac81cabaa56be8d2217961abfc026cbd0c0141aea3efb6c75b9daf2fe9f6fc0f09efd224d241fa859bd37bcd972df4e4837318497d774e SHA512 7b52d67b4d2c428a7b0c1cd03b03a23f05d38d7e3c81041079a137919019ea5158f12bf95fdcfcff6b43ffdefe93a85127ced2a363a6b4b380cbaa02a3840256
DIST qpdf-7.1.0.tar.gz 7097479 BLAKE2B 0d363d9d0b3ca2873b21bacfb2002f3ffa431848402fef5abe0079c9373835d483de1fb10b2b21ad8c9c14bb16f30ee8eb34f2465142f491295cede0790c54a7 SHA512 28c00f0e7e1d89ab8165031b7e741297d472801fd115911b5f970e97f27fb0c463169dad2d59bb35885de5989984bc5f31a9c26be42015c0dba41105ae342726
+DIST qpdf-7.1.1.tar.gz 7099282 BLAKE2B 9658dd1cc6f8d0e3dd13137db147e0f954f747b5bb6b1577f70a236b1f67c5513713889dca77181a9b25f1a2054a8ec5cbfda60866e97b2d43e60b494752c9fd SHA512 a75f988c7dd7ac174bdc981cd3696ca8b539ac6c581e3afecf601dc67277014cb4fe3f0e5cb75a67412cafa4eb645b2fc2d8a0ec203834464baf0c7e80baa0b4
diff --git a/app-text/qpdf/qpdf-7.1.1.ebuild b/app-text/qpdf/qpdf-7.1.1.ebuild
new file mode 100644
index 000000000000..df045305bb67
--- /dev/null
+++ b/app-text/qpdf/qpdf-7.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+
+# subslot = libqpdf soname version
+SLOT="0/18"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples perl static-libs test"
+
+CDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+"
+DEPEND="${CDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl[tiff]
+ )
+"
+# Only need perl for the installed tools.
+RDEPEND="${CDEPEND}
+ perl? ( >=dev-lang/perl-5.8 )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/fix-qdf || die
+ rm "${ED}"/usr/share/man/man1/fix-qdf.1 || die
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}