summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsgeir Bjarni Ingvarsson <asgeir@fundinn.org>2018-04-06 11:35:29 +0000
committerLars Wendler <polynomial-c@gentoo.org>2018-04-06 15:11:52 +0200
commitc7136dfab6a9b2dd25a8dd8f1eb5ad11c0dd527c (patch)
tree28e09787a0e36b8176196eb1684016da44d07006 /app-text
parentsys-apps/util-linux: Tested on ~amd64-fbsd (diff)
downloadgentoo-c7136dfab6a9b2dd25a8dd8f1eb5ad11c0dd527c.tar.gz
gentoo-c7136dfab6a9b2dd25a8dd8f1eb5ad11c0dd527c.tar.bz2
gentoo-c7136dfab6a9b2dd25a8dd8f1eb5ad11c0dd527c.zip
app-text/lesspipe: Switch to EAPI-6
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7832
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lesspipe/lesspipe-1.83-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/lesspipe/lesspipe-1.83-r1.ebuild b/app-text/lesspipe/lesspipe-1.83-r1.ebuild
new file mode 100644
index 000000000000..d62cceae539e
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.83-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ dodoc ChangeLog README TODO
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}