summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-02-23 21:43:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-02-23 21:43:43 +0300
commitd07bf461eeac79f8eac953f09f45450808e800af (patch)
treeb3049ced37ce80789a9c67a3b5b2517862fd9ef7 /app-text
parentsys-kernel/gentoo-sources: Linux patch 4.9.160 (diff)
downloadgentoo-d07bf461eeac79f8eac953f09f45450808e800af.tar.gz
gentoo-d07bf461eeac79f8eac953f09f45450808e800af.tar.bz2
gentoo-d07bf461eeac79f8eac953f09f45450808e800af.zip
app-text/wgetpaste: version bump to disable did paste service
Closes: https://bugs.gentoo.org/678552 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wgetpaste/files/wgetpaste-remove-dead.patch35
-rw-r--r--app-text/wgetpaste/wgetpaste-2.28-r2.ebuild29
2 files changed, 64 insertions, 0 deletions
diff --git a/app-text/wgetpaste/files/wgetpaste-remove-dead.patch b/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
new file mode 100644
index 000000000000..038d5349a7c6
--- /dev/null
+++ b/app-text/wgetpaste/files/wgetpaste-remove-dead.patch
@@ -0,0 +1,35 @@
+From 166ec045945eff08ca27129b38d2f5395710e8fb Mon Sep 17 00:00:00 2001
+From: Mikle Kolyada <zlogene@gentoo.org>
+Date: Sat, 23 Feb 2019 21:14:08 +0300
+Subject: [PATCH] fix wgetpaste services
+
+Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
+---
+ wgetpaste | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/wgetpaste b/wgetpaste
+index 2c198e0..def51de 100755
+--- a/wgetpaste
++++ b/wgetpaste
+@@ -14,7 +14,7 @@ E=$'\e'
+ N=$'\n'
+
+ ### services
+-SERVICES="codepad bpaste dpaste gists poundpython"
++SERVICES="codepad bpaste dpaste gists"
+ # bpaste
+ ENGINE_bpaste=pinnwand
+ URL_bpaste="https://bpaste.net/"
+@@ -722,7 +722,7 @@ load_configs() {
+ load_configs
+ [[ $SERVICESET ]] && verifyservice "$SERVICESET" && SERVICE=$(escape "$SERVICESET")
+ DEFAULT_NICK=${DEFAULT_NICK:-$(whoami)} || die "whoami failed"
+-DEFAULT_SERVICE=${DEFAULT_SERVICE:-poundpython}
++DEFAULT_SERVICE=${DEFAULT_SERVICE:-dpaste}
+ DEFAULT_LANGUAGE=${DEFAULT_LANGUAGE:-Plain Text}
+ DEFAULT_EXPIRATION=${DEFAULT_EXPIRATION:-1 month}
+ SERVICE=${SERVICE:-${DEFAULT_SERVICE}}
+--
+2.19.2
+
diff --git a/app-text/wgetpaste/wgetpaste-2.28-r2.ebuild b/app-text/wgetpaste/wgetpaste-2.28-r2.ebuild
new file mode 100644
index 000000000000..30f97b5311ac
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.28-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+ssl"
+
+DEPEND=""
+RDEPEND="net-misc/wget[ssl?]"
+
+PATCHES=( "${FILESDIR}"/${PN}-remove-dead.patch )
+
+src_prepare() {
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}