summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-05 00:01:24 +0000
committerSam James <sam@gentoo.org>2023-02-05 00:01:24 +0000
commite647fdc8f99057a7747c11863348e094c0ce7ab9 (patch)
tree84c26924675752d09e402ca49a53a5439cbb53bf /app-text
parentsys-apps/texinfo: drop 7.0.1, 7.0.1-r1 (diff)
downloadgentoo-e647fdc8f99057a7747c11863348e094c0ce7ab9.tar.gz
gentoo-e647fdc8f99057a7747c11863348e094c0ce7ab9.tar.bz2
gentoo-e647fdc8f99057a7747c11863348e094c0ce7ab9.zip
app-text/poppler-data: add 0.4.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-data/Manifest1
-rw-r--r--app-text/poppler-data/poppler-data-0.4.12.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/poppler-data/Manifest b/app-text/poppler-data/Manifest
index 9ad957e67027..8e27a6198e35 100644
--- a/app-text/poppler-data/Manifest
+++ b/app-text/poppler-data/Manifest
@@ -1,2 +1,3 @@
DIST poppler-data-0.4.11-2-extra.tar.xz 3124 BLAKE2B 8ae0cb7613d36e2ceddb77736b04a61353cf4bcd3ac74e6cc65e7ddf727b65b98aa57c31bc02782cd74318119f0577cb3b187c9192ee0bb47dc8666e908a919b SHA512 3e43bc37b1a9affe4fabf68c3ea3490cbae0892286b3fd01f60f2fd232da68bc863fe0b058821d7d2e4ac4d7427b0ab02f8374abeba2cad704d578a155f46885
DIST poppler-data-0.4.11.tar.gz 4497282 BLAKE2B 01f0f9f3d933f45683a702c4d538d8fc59874512290f199b601c16f98f9b596ff249fbc992574d046931cc80f3685f94733248450d3a54f2f961951cdeda7c39 SHA512 a5b7ace28d1677e12f7500ab6345b277dc22cd48ace8d472c083933416879edf4da4efe8217b0e11f75a3387ed98d832fe50567884095b6c0e09ebd8802b0f32
+DIST poppler-data-0.4.12.tar.gz 4504754 BLAKE2B 0d34ff1fcc9120b5db2baded9d931ca37128106eecdd54892d0256f9736f799d52eacd4017741797432048def914dd13150c6e3bf8d9ea5b8597a799a497d1c7 SHA512 75f201e4c586ba47eb9a48a33ef6663fe353d0694b602feb7db282d73da7f0daffb0ff7e18e4a6cb40324305efa2413df562666939f4214e2dfd7ff00288f3de
diff --git a/app-text/poppler-data/poppler-data-0.4.12.ebuild b/app-text/poppler-data/poppler-data-0.4.12.ebuild
new file mode 100644
index 000000000000..f30dc0b9ffac
--- /dev/null
+++ b/app-text/poppler-data/poppler-data-0.4.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+POPPLER_DATA_EXTRA_VERSION="0.4.11-2"
+DESCRIPTION="Data files for poppler to support uncommon encodings without xpdfrc"
+HOMEPAGE="https://poppler.freedesktop.org/"
+SRC_URI="https://poppler.freedesktop.org/${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-${POPPLER_DATA_EXTRA_VERSION}-extra.tar.xz"
+
+# AGPL-3+ for the extra files needed by ghostscript, bug #844115
+LICENSE="AGPL-3+ BSD GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+src_install() {
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+
+ # We need to include extra cMaps for ghostscript, bug #844115
+ cp "${WORKDIR}"/${PN}-${POPPLER_DATA_EXTRA_VERSION}-extra/Identity-* "${ED}"/usr/share/poppler/cMap || die
+
+ # bug #409361
+ dodir /usr/share/poppler/cMaps
+ cd "${ED}"/usr/share/poppler/cMaps || die
+ find ../cMap -type f -exec ln -s {} . \; || die
+}