summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-08-24 12:01:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-08-24 12:01:00 +0300
commiteee4e3d2774344992a174ed9478b366a1ac00e0f (patch)
tree14163733a605d3c88b579cf214855f52d7e4419a /app-text
parentapp-text/zathura-cb: call xdg_desktop_database_update (diff)
downloadgentoo-eee4e3d2774344992a174ed9478b366a1ac00e0f.tar.gz
gentoo-eee4e3d2774344992a174ed9478b366a1ac00e0f.tar.bz2
gentoo-eee4e3d2774344992a174ed9478b366a1ac00e0f.zip
app-text/zathura-ps: call xdg_desktop_database_update
Closes: https://bugs.gentoo.org/735702 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.6.ebuild12
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild12
2 files changed, 20 insertions, 4 deletions
diff --git a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
index 94dab249fb7a..e115907ec1e6 100644
--- a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
+++ b/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -29,3 +29,11 @@ DEPEND="app-text/libspectre
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
index 16e0d2d5ba33..1029752194f6 100644
--- a/app-text/zathura-ps/zathura-ps-9999.ebuild
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -29,3 +29,11 @@ DEPEND="app-text/libspectre
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}