summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-18 11:51:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-18 11:51:53 +0100
commitf4f32f600bdc3834c3ec16b07f6989e75f74c6dc (patch)
tree376387053efe236286e47cb98fd57ca22b01332a /app-text
parentnet-libs/libtrace: Old. (diff)
downloadgentoo-f4f32f600bdc3834c3ec16b07f6989e75f74c6dc.tar.gz
gentoo-f4f32f600bdc3834c3ec16b07f6989e75f74c6dc.tar.bz2
gentoo-f4f32f600bdc3834c3ec16b07f6989e75f74c6dc.zip
app-text/libmwaw: Add upstream buildfix
Reported-by: Coacher <itumaykin+gentoo@gmail.com> Thanks-to: Shannon <roamingangel@gmail.com> Closes: https://bugs.gentoo.org/637692 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmwaw/files/libmwaw-0.3.13-buildfix.patch19
-rw-r--r--app-text/libmwaw/libmwaw-0.3.13.ebuild2
2 files changed, 21 insertions, 0 deletions
diff --git a/app-text/libmwaw/files/libmwaw-0.3.13-buildfix.patch b/app-text/libmwaw/files/libmwaw-0.3.13-buildfix.patch
new file mode 100644
index 000000000000..5c9940e8860d
--- /dev/null
+++ b/app-text/libmwaw/files/libmwaw-0.3.13-buildfix.patch
@@ -0,0 +1,19 @@
+commit 4bc8ec0481f89b989b0c34236c9d5d9b8038d4a9
+Author: David Tardon <dtardon@redhat.com>
+Date: Wed Nov 15 13:15:44 2017 +0100
+
+ fix call of explicit ctor
+
+diff --git a/src/lib/libmwaw_internal.hxx b/src/lib/libmwaw_internal.hxx
+index 2875a0fb..b844a9d5 100644
+--- a/src/lib/libmwaw_internal.hxx
++++ b/src/lib/libmwaw_internal.hxx
+@@ -1027,7 +1027,7 @@ public:
+ }
+ //! generic constructor
+ template <class U> explicit MWAWBox2(MWAWBox2<U> const &p)
+- : m_data(p.min(), p.max())
++ : m_data(MWAWVec2<T>(p.min()), MWAWVec2<T>(p.max()))
+ {
+ }
+
diff --git a/app-text/libmwaw/libmwaw-0.3.13.ebuild b/app-text/libmwaw/libmwaw-0.3.13.ebuild
index 0b26fe70b823..bd2d45589301 100644
--- a/app-text/libmwaw/libmwaw-0.3.13.ebuild
+++ b/app-text/libmwaw/libmwaw-0.3.13.ebuild
@@ -28,6 +28,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
"
+PATCHES=( "${FILESDIR}/${P}-buildfix.patch" )
+
src_prepare() {
default
[[ ${PV} == 9999 ]] && eautoreconf