summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-07 10:58:53 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-07 10:58:53 +0100
commitfeec28a2c092c6cb95f391119a42f56800b6e233 (patch)
tree090fe24e2b5e4b04b2c19cc4699fbb89ab6afec9 /app-text
parentsci-biology/bcftools: fix PYTHON_COMPAT, add missing matplotlib dep (diff)
downloadgentoo-feec28a2c092c6cb95f391119a42f56800b6e233.tar.gz
gentoo-feec28a2c092c6cb95f391119a42f56800b6e233.tar.bz2
gentoo-feec28a2c092c6cb95f391119a42f56800b6e233.zip
app-text/ttf2pk2: Fix building with GCC 10
Closes: https://bugs.gentoo.org/707294 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch21
-rw-r--r--app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild4
2 files changed, 24 insertions, 1 deletions
diff --git a/app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch b/app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch
new file mode 100644
index 000000000000..74678208a240
--- /dev/null
+++ b/app-text/ttf2pk2/files/ttf2pk2-2.0_p20190410-fno-common-gcc10.patch
@@ -0,0 +1,21 @@
+--- a/pklib.c
++++ b/pklib.c
+@@ -64,8 +64,6 @@
+ #define PK_POST (char)245
+ #define PK_NOP (char)246
+
+-int dpi;
+-
+ FILE *pk_file;
+
+
+--- a/pklib.h
++++ b/pklib.h
+@@ -13,6 +13,7 @@
+
+ typedef unsigned char byte;
+
++extern int dpi;
+
+ void TFMopen(char **filename);
+
diff --git a/app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild b/app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild
index 6499ac50b3ec..6528f2d15c05 100644
--- a/app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild
+++ b/app-text/ttf2pk2/ttf2pk2-2.0_p20190410.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,8 @@ BDEPEND="virtual/pkgconfig"
S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+PATCHES=( "${FILESDIR}"/${PN}-2.0_p20190410-fno-common-gcc10.patch )
+
src_configure() {
econf --with-system-kpathsea \
--with-system-freetype2 \