summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-20 21:45:51 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-06-21 19:35:14 +0000
commitf58d475f5ce31d310ec075b12284431877b82e88 (patch)
treecaaf02e9e297d3e71a65b117410e909a9a1443d1 /app-vim/breakpts
parentapp-i18n/poedit: Fix := slot op in || dep, #586310 (diff)
downloadgentoo-f58d475f5ce31d310ec075b12284431877b82e88.tar.gz
gentoo-f58d475f5ce31d310ec075b12284431877b82e88.tar.bz2
gentoo-f58d475f5ce31d310ec075b12284431877b82e88.zip
app-vim/breakpts: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/breakpts')
-rw-r--r--app-vim/breakpts/breakpts-4.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/breakpts/breakpts-4.0-r1.ebuild b/app-vim/breakpts/breakpts-4.0-r1.ebuild
new file mode 100644
index 000000000000..05d6ab185cb2
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=618"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."