summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/colorv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/colorv')
-rw-r--r--app-vim/colorv/Manifest3
-rw-r--r--app-vim/colorv/colorv-2.5.3.ebuild32
-rw-r--r--app-vim/colorv/colorv-2.5.6.ebuild26
-rw-r--r--app-vim/colorv/colorv-3.0.2.ebuild26
-rw-r--r--app-vim/colorv/metadata.xml5
5 files changed, 92 insertions, 0 deletions
diff --git a/app-vim/colorv/Manifest b/app-vim/colorv/Manifest
new file mode 100644
index 000000000000..467ad76bd904
--- /dev/null
+++ b/app-vim/colorv/Manifest
@@ -0,0 +1,3 @@
+DIST colorv-2.5.3.tar.gz 48636 SHA256 46ae0a4870e18e3358f90efd54e1c98951d5c3f11cb85220f4480d05e9382ded SHA512 a4db26d189756f84339aec32cc406bf9fc8ac8a1fed0ad58c1f5110edc9cfac3d3f4f5af410c8cecbcced7b4c406e9fe78ecbb7d863b7e6ba7fae50b7ba32863 WHIRLPOOL c81c2250146fa20a20a09dd0cd3197d9a249d35cd1e12d8188392a9046c4947cfa2c4ba081fa4ecc97462ece22ba96b9f771db1ba9f18b3e444e336a35d33c32
+DIST colorv-2.5.6.tar.bz2 40591 SHA256 5843d0f5aa5aa4bc71ec281edca3e3391c8ccc0b9025405751edb6b16399f824 SHA512 e6b5e1653080b2045028dd71e5839dda08a042c9970d27d1bfd47417c42020cb2cd68940c80e6f998a3a3adc723ee91c480a8bd55c711086a19d4c24b368e38e WHIRLPOOL 4fef5fb226b00f2f0172493e85df6758dbb007fc36e3dc75758cca7a68928c41467de76c9c8da065456b0c4695bf2bc8c1bed8f9a998c11f41089bbc13953864
+DIST colorv-3.0.2.tar.bz2 47059 SHA256 75a570021678a58225b346fa87aa13919ef84757a4cd5344855d101835ab231b SHA512 cb4a893d65bbada5cec27c0810bf3e78db3c64e64f4179529d5da30402ab65b141f53dd7f2a9e8bbccf3d5f7dc5843afc7cab0d908e66a86fc41a5c38c9a848e WHIRLPOOL 5fd18f5d6686717e628e136c8025041cbc0820ae394e3c7e1a19245fe02142770d911d505c1cc5efcf9ea29739faae31d72ef83543b833f116bd52f4ad9c37f0
diff --git a/app-vim/colorv/colorv-2.5.3.ebuild b/app-vim/colorv/colorv-2.5.3.ebuild
new file mode 100644
index 000000000000..cff07f505512
--- /dev/null
+++ b/app-vim/colorv/colorv-2.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vim-plugin
+
+MY_PN="ColorV"
+DESCRIPTION="vim plugin: a color tool for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3597"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ || (
+ app-editors/vim[python]
+ ( app-editors/gvim[python] dev-python/pygtk:2 )
+ )"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README* || die
+}
diff --git a/app-vim/colorv/colorv-2.5.6.ebuild b/app-vim/colorv/colorv-2.5.6.ebuild
new file mode 100644
index 000000000000..a563becdc52d
--- /dev/null
+++ b/app-vim/colorv/colorv-2.5.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a color tool for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3597"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="
+ || (
+ app-editors/vim[python]
+ ( app-editors/gvim[python] dev-python/pygtk:2 )
+ )"
+
+src_prepare() {
+ # use python colorpicker instead of C-based picker
+ rm autoload/colorv/{colorpicker.c,Makefile} || die
+}
diff --git a/app-vim/colorv/colorv-3.0.2.ebuild b/app-vim/colorv/colorv-3.0.2.ebuild
new file mode 100644
index 000000000000..0b7cd6455cb9
--- /dev/null
+++ b/app-vim/colorv/colorv-3.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: a color tool for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3597"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="
+ || (
+ app-editors/vim[python]
+ ( app-editors/gvim[python] dev-python/pygtk:2 )
+ )"
+
+src_prepare() {
+ # use python colorpicker instead of C-based picker
+ rm autoload/colorv/{colorpicker.c,Makefile} || die
+}
diff --git a/app-vim/colorv/metadata.xml b/app-vim/colorv/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/colorv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>