summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-01-22 23:58:12 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-01-22 23:58:12 +0100
commitb94835f2b9052bb1f1d89869d409e890ccf5dc3b (patch)
tree446a9109c4d4556b6738c062041950c6f801806a /app-vim/easy-align
parentapp-vim/gentoo-syntax: clean up old. (diff)
downloadgentoo-b94835f2b9052bb1f1d89869d409e890ccf5dc3b.tar.gz
gentoo-b94835f2b9052bb1f1d89869d409e890ccf5dc3b.tar.bz2
gentoo-b94835f2b9052bb1f1d89869d409e890ccf5dc3b.zip
app-vim/easy-align: EAPI 6 bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 RepoMan-Options: --force
Diffstat (limited to 'app-vim/easy-align')
-rw-r--r--app-vim/easy-align/easy-align-2.10.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/easy-align/easy-align-2.10.0-r1.ebuild b/app-vim/easy-align/easy-align-2.10.0-r1.ebuild
new file mode 100644
index 000000000000..dcb2ed0da094
--- /dev/null
+++ b/app-vim/easy-align/easy-align-2.10.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a simple alignment plugin"
+HOMEPAGE="https://github.com/junegunn/vim-easy-align https://www.vim.org/scripts/script.php?script_id=4520"
+SRC_URI="https://github.com/junegunn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ rm -rv test || die
+}