summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-11-07 14:20:20 -0800
committerPatrick McLean <chutzpah@gentoo.org>2016-11-07 14:20:20 -0800
commit84e3433981a6ef9e9264f09a2508aec1346c44c0 (patch)
treea0b245141c5a9e58e55910c64f51deff0268d517 /app-vim/editorconfig-vim
parentdev-python/editorconfig-core-py: New package, python implementation of Editor... (diff)
downloadgentoo-84e3433981a6ef9e9264f09a2508aec1346c44c0.tar.gz
gentoo-84e3433981a6ef9e9264f09a2508aec1346c44c0.tar.bz2
gentoo-84e3433981a6ef9e9264f09a2508aec1346c44c0.zip
app-vim/editorconfig-vim: Revision bump, use external editorconfig-core-py instead of bundled version
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-vim/editorconfig-vim')
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r1.ebuild29
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-0.3.3.ebuild46
2 files changed, 29 insertions, 46 deletions
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r1.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..8fffa6e241f5
--- /dev/null
+++ b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_4 python3_5)
+inherit python-r1 vim-plugin
+
+DESCRIPTION="vim plugin: Support EditorConfig files "
+HOMEPAGE="http://editorconfig.org/"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DEPEND="dev-python/editorconfig-core-py[${PYTHON_USEDEP}]
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+)"
+
+VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"
+
+src_prepare() {
+ default
+
+ rm LICENSE mkzip.sh .editorconfig .gitignore .travis.yml || die
+ rm -r tests plugin/${PN%-vim}-core-py || die
+}
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3.ebuild
deleted file mode 100644
index fa2719b5037b..000000000000
--- a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=(python2_7)
-inherit vim-plugin distutils-r1
-
-DESCRIPTION="vim plugin: Support EditorConfig files "
-HOMEPAGE="http://editorconfig.org/"
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-DEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
-
-VIM_PLUGIN_HELPFILES="${PN%-vim}.txt"
-
-PYTHON_S="${S}/plugin/${PN%-vim}-core-py"
-
-src_prepare() {
- default
- pushd "${PYTHON_S}" > /dev/null
- python_setup
- distutils-r1_src_prepare
- popd > /dev/null
-
- rm LICENSE mkzip.sh .editorconfig .gitignore .travis.yml || die
- rm -r tests || die
-}
-
-python_compile() {
- pushd "${PYTHON_S}" > /dev/null
- distutils-r1_python_compile
- popd > /dev/null
-}
-
-src_install() {
- pushd "${PYTHON_S}" > /dev/null
- distutils-r1_src_install
- popd > /dev/null
-
- rm -r "${PYTHON_S}"
- vim-plugin_src_install
-}