summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-30 20:47:21 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-30 20:49:48 -0700
commite3faaf4d8eedf881b00379e2be2019a5cf688728 (patch)
treeaa5377260092640ba75c34504a76e87d409fc23b /app-vim/fugitive/fugitive-3.2.ebuild
parentapp-vim/merginal: version bump to 2.1.2 (diff)
downloadgentoo-e3faaf4d8eedf881b00379e2be2019a5cf688728.tar.gz
gentoo-e3faaf4d8eedf881b00379e2be2019a5cf688728.tar.bz2
gentoo-e3faaf4d8eedf881b00379e2be2019a5cf688728.zip
app-vim/fugitive: version bump to 3.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/fugitive/fugitive-3.2.ebuild')
-rw-r--r--app-vim/fugitive/fugitive-3.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/fugitive/fugitive-3.2.ebuild b/app-vim/fugitive/fugitive-3.2.ebuild
new file mode 100644
index 000000000000..0d4da8993529
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"