summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 16:52:55 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 16:52:55 -0400
commit58de80073322333ee2a0468c3cfcc46829aec671 (patch)
tree332dc97855ce2769033b98a00118797b49193937 /app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild
parentapp-vim/merginal: add live ebuild (diff)
downloadgentoo-58de80073322333ee2a0468c3cfcc46829aec671.tar.gz
gentoo-58de80073322333ee2a0468c3cfcc46829aec671.tar.bz2
gentoo-58de80073322333ee2a0468c3cfcc46829aec671.zip
app-vim/nerdcommenter: version bump to 2.5.0 add add live ebuild
Diffstat (limited to 'app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild')
-rw-r--r--app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild b/app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild
new file mode 100644
index 000000000000..5d3f9f95e5f9
--- /dev/null
+++ b/app-vim/nerdcommenter/nerdcommenter-2.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/scrooloose/nerdcommenter.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x86-linux ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="vim plugin: easy commenting of code for many filetypes"
+HOMEPAGE="https://github.com/scrooloose/nerdcommenter http://www.vim.org/scripts/script.php?script_id=1218"
+LICENSE="WTFPL-2 "
+
+VIM_PLUGIN_HELPFILES="NERD_commenter.txt"
+
+src_prepare() {
+ default
+ rm README.md Rakefile || die
+}