summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/rust-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/rust-mode')
-rw-r--r--app-vim/rust-mode/Manifest1
-rw-r--r--app-vim/rust-mode/metadata.xml8
-rw-r--r--app-vim/rust-mode/rust-mode-1_beta20150411.ebuild18
3 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/rust-mode/Manifest b/app-vim/rust-mode/Manifest
new file mode 100644
index 000000000000..4b772f0ce0cb
--- /dev/null
+++ b/app-vim/rust-mode/Manifest
@@ -0,0 +1 @@
+DIST rust-mode-vim-1_beta20150411.tar.gz 14834 SHA256 ae10727c14612905f489afea1146bac24a0ea6309a3a3fcf97a048dd1e156eb4 SHA512 f841768909203475a0cd3589a148d334001351fb23976ee28823a9dbde396d89a4f3c5ac07166420c8ddb64692dcc86b98b3afc3579171115a3a2af17b6aa449 WHIRLPOOL c95fc23f40608be817c7fc7467138efaa25a6b24427b79ab0de7daf84e5f32c4f2cd0db1377e2eaa0e40bf83cb765c86f6e04752b142b1779c194ceddc8b7d07
diff --git a/app-vim/rust-mode/metadata.xml b/app-vim/rust-mode/metadata.xml
new file mode 100644
index 000000000000..0b7db932cfa4
--- /dev/null
+++ b/app-vim/rust-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/rust-mode/rust-mode-1_beta20150411.ebuild b/app-vim/rust-mode/rust-mode-1_beta20150411.ebuild
new file mode 100644
index 000000000000..9db3b5b4f78b
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-1_beta20150411.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="${PN}-vim"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Rust mode for vim"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://dev.gentoo.org/~jauhien/distfiles/${MY_P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"