summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/syntastic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/syntastic')
-rw-r--r--app-vim/syntastic/Manifest2
-rw-r--r--app-vim/syntastic/metadata.xml8
-rw-r--r--app-vim/syntastic/syntastic-3.5.0.ebuild27
-rw-r--r--app-vim/syntastic/syntastic-3.6.0.ebuild33
-rw-r--r--app-vim/syntastic/syntastic-9999.ebuild33
5 files changed, 103 insertions, 0 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
new file mode 100644
index 000000000000..745a477436ae
--- /dev/null
+++ b/app-vim/syntastic/Manifest
@@ -0,0 +1,2 @@
+DIST syntastic-3.5.0.tar.gz 181707 SHA256 3e86936612e279bf5a5dc3e8ec7d7ce64277453ae05b17579e662fd6271e6313 SHA512 052470c359c9ec2d13b1d3a39f2f40c798b06f75a17ee77b81e2d72ccf9b59b2b676c211a3cb4f855111ad2af0ad08ce1cadd32c72329ae7961a9410d52bbf98 WHIRLPOOL d9c9bceeeb815a1fe95c9585761ac87dafafdadae2910b5fbdf63c946ec2d222887384f5ac4f7346f122706668433de4d628f61b1202dc9f3d9b8f0a0bc412a1
+DIST syntastic-3.6.0.tar.gz 189617 SHA256 b47c5ad0290f7f8e5fda49fde996258509c939b0244de812bed847de1d2a0557 SHA512 855577a796ffd8e9077d4f900928beba3f5f78348f81d39a776c7659713be75170285b421e8751b06639100a2580a2b7fc5f1e4aefb4c7225dc6b2f11ef02e25 WHIRLPOOL 5df8dc3a01f14e4e83366b37d819efb176cf17d49cbfe4a14ce990a4027eb4e507e29a3e408f472b637f180713d969b88a298fb0cf4edd3deaa02dad79b0fdb1
diff --git a/app-vim/syntastic/metadata.xml b/app-vim/syntastic/metadata.xml
new file mode 100644
index 000000000000..847bbf0fce2c
--- /dev/null
+++ b/app-vim/syntastic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">scrooloose/syntastic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/syntastic/syntastic-3.5.0.ebuild b/app-vim/syntastic/syntastic-3.5.0.ebuild
new file mode 100644
index 000000000000..c2b454f4c0ae
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="WTFPL-2"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}
diff --git a/app-vim/syntastic/syntastic-3.6.0.ebuild b/app-vim/syntastic/syntastic-3.6.0.ebuild
new file mode 100644
index 000000000000..be5b783accd2
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}
diff --git a/app-vim/syntastic/syntastic-9999.ebuild b/app-vim/syntastic/syntastic-9999.ebuild
new file mode 100644
index 000000000000..be5b783accd2
--- /dev/null
+++ b/app-vim/syntastic/syntastic-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}