summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-07 08:15:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-07 10:35:04 +0000
commita022c6369464a94a3b28720d28aa4928e799ec7c (patch)
tree696fbdc31698360153a7378c03c7a7c5c7a3a358 /app-vim/vim-flake8
parentapp-office/upwork: Remove Old (diff)
downloadgentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.tar.gz
gentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.tar.bz2
gentoo-a022c6369464a94a3b28720d28aa4928e799ec7c.zip
app-vim/vim-flake8: Add vim-flake8 vim script.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/vim-flake8')
-rw-r--r--app-vim/vim-flake8/Manifest1
-rw-r--r--app-vim/vim-flake8/metadata.xml8
-rw-r--r--app-vim/vim-flake8/vim-flake8-1.6.ebuild16
3 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/vim-flake8/Manifest b/app-vim/vim-flake8/Manifest
new file mode 100644
index 000000000000..d3f8eed40194
--- /dev/null
+++ b/app-vim/vim-flake8/Manifest
@@ -0,0 +1 @@
+DIST vim-flake8-1.6.zip 6499 SHA256 c35dc818ef8fee8bb0e8f4519b417be10ff4297322930c27ead75f8e3cb5bf24 SHA512 2cd6427d946d3ab310c9d04441355545065f501d9176b11e90a2df5b8c0fad679f56b77e934f9cf4078a947f8f35d0200411add0da34f33e6cfef4b9b4089c98 WHIRLPOOL 56dacac8e135e3601a9dfb66d4a6d4dee1a5570843eca748c139c84156705ddafd95f4a02a96df3e0d38adcf1f30f19565174c654758c699d62990479e867c8b
diff --git a/app-vim/vim-flake8/metadata.xml b/app-vim/vim-flake8/metadata.xml
new file mode 100644
index 000000000000..84f8f1cf6bcb
--- /dev/null
+++ b/app-vim/vim-flake8/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-flake8/vim-flake8-1.6.ebuild b/app-vim/vim-flake8/vim-flake8-1.6.ebuild
new file mode 100644
index 000000000000..2b924a52a00b
--- /dev/null
+++ b/app-vim/vim-flake8/vim-flake8-1.6.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: runs the currently open file through flake8"
+HOMEPAGE="https://github.com/nvie/vim-flake8"
+SRC_URI="https://github.com/nvie/${PN}/archive/${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/flake8"