summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-21 17:37:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-21 18:04:47 +0200
commit0199924af14044f59a9a0dd881eb9c7d92868b44 (patch)
tree7655456df895c04536e73b0165044cac27a3dad3 /app-vim
parentapp-vim/vim-latex: add python{3_7,3_8} targets. (diff)
downloadgentoo-0199924af14044f59a9a0dd881eb9c7d92868b44.tar.gz
gentoo-0199924af14044f59a9a0dd881eb9c7d92868b44.tar.bz2
gentoo-0199924af14044f59a9a0dd881eb9c7d92868b44.zip
app-vim/notes: various fixes.
* EAPI 7 bump. * add python{3_6,3_7,3_8} targets. Bug: https://bugs.gentoo.org/708982 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/notes/notes-0.33.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/notes/notes-0.33.4-r1.ebuild b/app-vim/notes/notes-0.33.4-r1.ebuild
new file mode 100644
index 000000000000..d436975d1828
--- /dev/null
+++ b/app-vim/notes/notes-0.33.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+PYTHON_REQ_USE="sqlite"
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: easy note taking in vim"
+HOMEPAGE="http://peterodding.com/code/vim/notes/"
+SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-vim/vim-misc"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S="${WORKDIR}/vim-${P}"
+
+src_prepare() {
+ default
+
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+
+ python_fix_shebang "${S}"
+}