summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-04 15:49:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-04 16:34:24 +0100
commit07daea7fea0495ce3f37929400d4b6deade15f70 (patch)
treea6f33fca2b2f0339cf30e041dc87f0ffa5c627d7 /app-vim
parentprofiles/package.mask: mask logue for removal (diff)
downloadgentoo-07daea7fea0495ce3f37929400d4b6deade15f70.tar.gz
gentoo-07daea7fea0495ce3f37929400d4b6deade15f70.tar.bz2
gentoo-07daea7fea0495ce3f37929400d4b6deade15f70.zip
app-vim/gentoo-syntax: Bump to v4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 5b1f5d4c507c..cd0c2bea7926 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-2.tar.bz2 20302 BLAKE2B fa15fe5e8ef547dfa402b1742df3d6d38231528bcf6c6836e4d31e81ec2bce55ffa8c10400823c97688304f9dc6324ed3d257939c3077eb29a2fc3c191295604 SHA512 30e8e374382dc736febd1ee8031a7ccc14dfc61feade1815e3366988658189ac8670ff26532436ae608ff66c828e2de7327d0b39db37967206bcd9f418d26ea2
+DIST gentoo-syntax-4.tar.bz2 20344 BLAKE2B 3e9b75c1e9e395e04547a95bb6abd17e7404389ccc5a47d9cf9ca2973a55666ce17607c72fbd15a9b167033bf0f7d1447817b9346d56e2ddbd48c2acbdfdcffa SHA512 4aec2c40c4f582f697cc11ac73fe9301ce25bb38f240cc3c9e426247a4bd38fb83aa05407b65ac68313793735eafc71a3b1b55e0db4301941afe7c720a51bc85
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild
new file mode 100644
index 000000000000..6a2bb2bc0937
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}