summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-05 20:25:37 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-05 20:27:48 +0000
commit5dd148ba7bc693de51589fc96d59a4aac3f2f35d (patch)
treed80e14b9e191b671df6a162e5d0f61797cca3d22 /app-vim
parentprofiles: Mask dev-libs/ptypes (diff)
downloadgentoo-5dd148ba7bc693de51589fc96d59a4aac3f2f35d.tar.gz
gentoo-5dd148ba7bc693de51589fc96d59a4aac3f2f35d.tar.bz2
gentoo-5dd148ba7bc693de51589fc96d59a4aac3f2f35d.zip
app-vim/vimclojure: Rename duplicate files.
Instead of setting a blocker, create a for-loop that goes through duplicate files and renames them on the fly. Gentoo-Bug: https://bugs.gentoo.org/578082 Package-Manager: portage-2.2.26 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/vimclojure/vimclojure-2.3.6-r2.ebuild b/app-vim/vimclojure/vimclojure-2.3.6-r2.ebuild
new file mode 100644
index 000000000000..fa807de7acbb
--- /dev/null
+++ b/app-vim/vimclojure/vimclojure-2.3.6-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="VimClojure"
+
+DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
+HOMEPAGE="https://github.com/vim-scripts/VimClojure"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.zip"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/clojure"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# Files with similar names are already installed by app-vim/slimv.
+DUPLICATE_FILES=(
+ indent/clojure.vim
+ ftdetect/clojure.vim
+)
+
+src_prepare() {
+ find . -type f -name \*.bat -exec rm -v {} \; || die
+
+ # Let's simply rename them.
+ for file in "${DUPLICATE_FILES[@]}"; do
+ [[ -f "${file}" ]] || die "Couldn't find: ${file}"
+ bname=$(basename "${file}")
+ path=$(dirname "${file}")
+ noext="${bname%%.*}"
+ newname="${path}/${PN}_${noext}.vim"
+ mv "${file}" "${newname}" || die
+ done
+}
+
+src_install() {
+ local my_license="doc/LICENSE.txt"
+ dodoc "${my_license}"
+ rm -v "${my_license}" || die
+ vim-plugin_src_install
+}