summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-05-07 22:40:27 -0400
committerTim Harder <radhermit@gentoo.org>2016-05-07 22:47:24 -0400
commit5e1fa77dcd66b9703db3f4f6a95ef4c18f07ccae (patch)
tree2f57be5587be113c18c07725ee3fc8ef2eed0524 /app-vim
parentdev-qt/qtwebengine: add a few missing deps and several slot operators (diff)
downloadgentoo-5e1fa77dcd66b9703db3f4f6a95ef4c18f07ccae.tar.gz
gentoo-5e1fa77dcd66b9703db3f4f6a95ef4c18f07ccae.tar.bz2
gentoo-5e1fa77dcd66b9703db3f4f6a95ef4c18f07ccae.zip
app-vim/command-t: version bump to 3.0.2
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/command-t/Manifest1
-rw-r--r--app-vim/command-t/command-t-3.0.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/command-t/Manifest b/app-vim/command-t/Manifest
index d013016119ce..6033567f0543 100644
--- a/app-vim/command-t/Manifest
+++ b/app-vim/command-t/Manifest
@@ -1,2 +1,3 @@
DIST command-t-1.11.4.tar.bz2 43107 SHA256 8b3b9b70397621d23e74c817f5807319f769253cf82de471913294a8e702ab62 SHA512 d3e35e6c0c144338c3966c6b57822193080ed1ef181ccd2d6ecd480dbe023788d33d82518a8461a7525ee3d4ca9fc643beb250e18aa7cfd691c6bc6aad4a6644 WHIRLPOOL e92fe0ae2b8ec1e5e029be21fd02142b241321e3a15fed5e6e522f64e55daf0d3eb348eedfd0bdad712d130ced10b3116328428379f2ae92f60304b2379c676c
DIST command-t-1.13.tar.bz2 45385 SHA256 f5674a4c9dfaf8364deb694d2c4a579520a3921e8378dee32acc0849e1576c1f SHA512 dfa2905d0e9473b847a33c6721598f67e9354c817adc21c4a18bcb63b880f1808f1c7ebee2500c7ae48537b9a1a28c1293f421b06715b80fb54b983a56778002 WHIRLPOOL 3692a85c57690ddddee4978e5189fade9bc1a5f723cf63e22247ca85e9170aa3a23f85ad61cb5c5fca353ac2e2b9560140397fc7b1537653ec8a4ba617e9bb50
+DIST command-t-3.0.2.tar.gz 69434 SHA256 f849ef6a4bcf2fa53f4a7f76333a12c0a29c5eac13b36f1a79fdbee0ceea39ac SHA512 35c90a08d807dbbdc9428c1ca35d085bea16111f232063a37fc7ffe954549a53f7cb4e1ea80cf8da7e9dfb6159745af361843a3f15477e80c8f81de51af2ddca WHIRLPOOL c01be35bb9a440eef5b5bf5f47612f3432e58a7ba1bb3f1e0f54b6421d3983d5f39f198e6bb799866c953ed358e25e381c2e915f1b4935a775038bab592df6a4
diff --git a/app-vim/command-t/command-t-3.0.2.ebuild b/app-vim/command-t/command-t-3.0.2.ebuild
new file mode 100644
index 000000000000..cb5ad97a0389
--- /dev/null
+++ b/app-vim/command-t/command-t-3.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025 https://github.com/wincent/command-t"
+SRC_URI="https://github.com/wincent/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN} || die
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN} || die
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto "${sitelibdir}"
+ doins -r ruby/*
+}
+
+all_ruby_install() {
+ rm Gemfile* *.gemspec Rakefile LICENSE README.md || die
+ rm -r appstream bin fixtures data ruby spec vendor || die
+ find "${S}" -name .gitignore -delete || die
+
+ vim-plugin_src_install
+}