summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-02 23:52:56 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-02 23:53:19 +0200
commit7768bf09cf044c36623435166cbce2d1b7897f3a (patch)
tree54f77e9c6216b3d454a0b961584de325f47e0ea1 /app-vim
parentapp-office/calligra: Drop 3.2.0 (diff)
downloadgentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.tar.gz
gentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.tar.bz2
gentoo-7768bf09cf044c36623435166cbce2d1b7897f3a.zip
app-vim/iris: new ebuild.
iris an IMAP mail client for vim. Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/iris/Manifest1
-rw-r--r--app-vim/iris/iris-1.0.0.ebuild37
-rw-r--r--app-vim/iris/metadata.xml14
3 files changed, 52 insertions, 0 deletions
diff --git a/app-vim/iris/Manifest b/app-vim/iris/Manifest
new file mode 100644
index 000000000000..7d93223a466c
--- /dev/null
+++ b/app-vim/iris/Manifest
@@ -0,0 +1 @@
+DIST iris-1.0.0.tar.gz 15607 BLAKE2B f78155c7cdfce046c48f9a29ca2855212ebd5d7f5aabd7b3a605ca8257b1a99e6d0c005c3641f69a33f6d3b2335b2a68da9653c2487b4f5863ba96cc3323ee10 SHA512 0b8b74935c2844dbb874e18683fd65602820c13dfc50cc73425ac80440f898432eb1eb4af6e3b73cef5733ea9e7c1aa97d19f67e6d1a277592c359519dcc418c
diff --git a/app-vim/iris/iris-1.0.0.ebuild b/app-vim/iris/iris-1.0.0.ebuild
new file mode 100644
index 000000000000..8e10bcffdb96
--- /dev/null
+++ b/app-vim/iris/iris-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit vim-plugin python-r1
+
+MY_PN="iris.vim"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: mail client for vim"
+HOMEPAGE="https://github.com/soywod/iris.vim"
+SRC_URI="https://github.com/soywod/iris.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/imapclient
+ ${PYTHON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ mv api.py iris-api || die
+ mv idle.py iris-idle || die
+ sed -e 's#api\.py#iris-api#g;' -i autoload/iris/api.vim || die
+ sed -e 's#idle\.py#iris-idle#g;' -i autoload/iris/idle.vim || die
+ python_foreach_impl python_doscript iris-api
+ python_foreach_impl python_doscript iris-idle
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/iris/metadata.xml b/app-vim/iris/metadata.xml
new file mode 100644
index 000000000000..8ecaaddf7147
--- /dev/null
+++ b/app-vim/iris/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">soywod/iris.vim</remote-id>
+ </upstream>
+</pkgmetadata>