summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-05-29 23:26:28 -0400
committerTim Harder <radhermit@gentoo.org>2016-05-29 23:30:01 -0400
commitb5435eeb5778fc22f2323822af7c4d9a29f651c4 (patch)
tree2160b17a76b7cd80f80616b5e302d71813d0eeef /app-vim
parentdev-python/multidict: add ~x86 keyword (diff)
downloadgentoo-b5435eeb5778fc22f2323822af7c4d9a29f651c4.tar.gz
gentoo-b5435eeb5778fc22f2323822af7c4d9a29f651c4.tar.bz2
gentoo-b5435eeb5778fc22f2323822af7c4d9a29f651c4.zip
app-vim/gentoo-syntax: version bump to 20160530
Also, minor trimming of DESCRIPTION.
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20150823.ebuild2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild54
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild17
4 files changed, 68 insertions, 6 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index d06780a9ae96..3756862f8a74 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-20150823.tar.bz2 25848 SHA256 72eba1cf2d0ffb481aa5bc56dbdeb2a9172565cfd3b454ce56eb9fdf665ec6ca SHA512 9d6f82aba6aa33f5d49dfd085628aacb7584614acf82954fa0e814b7fac5eda47c8d3eb6672ad38144a1444d507babad8805ea3029ccc35210a8752ea10eab82 WHIRLPOOL 85cebe212b1e86e79e92b55b7456da7d053973877485c9855580308b49d892fffc2fdbf98c6be2c7df843bf72246a5251d4716f25fc010afeace6255f9e0a9f5
+DIST gentoo-syntax-20160530.tar.gz 18950 SHA256 819495c10e594b2fef1fdcd80afa24ee437fe20b94ad9e7eb9e91f0a5be31919 SHA512 38881c5f16499eb053eb7a5514f6324b2a161f1392a044db0bbaf0cb71a0f17e1edebd4a685ff856a78525fbcb8c6267daa2503cfbc6f94d841cf3f6a25045bd WHIRLPOOL 41018200b7f79eec005f55e80d3f8b1eec1f33acdbf1a8bce03b282a27cf63bb08a4959e0fcd74ecc9972322bbf4b0b89755dbde35cedc87ee9a228d07519a33
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20150823.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20150823.ebuild
index 301315341d2e..a0f79f30d1ab 100644
--- a/app-vim/gentoo-syntax/gentoo-syntax-20150823.ebuild
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20150823.ebuild
@@ -6,7 +6,7 @@ EAPI=5
inherit vim-plugin
-DESCRIPTION="vim plugin: Gentoo and portage related syntax highlighting, filetype, and indent settings"
+DESCRIPTION="Gentoo and portage related syntax highlighting, filetype, and indent settings"
HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild
new file mode 100644
index 000000000000..5a4e2c958a69
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Gentoo and portage related syntax highlighting, filetype, and indent settings"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+LICENSE="vim"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ fi
+}
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
index de309d8c8e2e..5a4e2c958a69 100644
--- a/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
+++ b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
@@ -1,14 +1,20 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit vim-plugin git-2
+inherit vim-plugin
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoo-syntax.git"
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
-DESCRIPTION="vim plugin: Gentoo and portage related syntax highlighting, filetype, and indent settings"
+DESCRIPTION="Gentoo and portage related syntax highlighting, filetype, and indent settings"
HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
LICENSE="vim"
IUSE="ignore-glep31"
@@ -17,6 +23,7 @@ VIM_PLUGIN_HELPFILES="gentoo-syntax"
VIM_PLUGIN_MESSAGES="filetype"
src_prepare() {
+ default
if use ignore-glep31 ; then
for f in ftplugin/*.vim ; do
ebegin "Removing UTF-8 rules from ${f} ..."