summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-05-13 08:15:42 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-05-13 08:23:38 +0000
commitbbd410a7dbce30963a0d36a354cb3bdf02f07399 (patch)
tree1dd6b9920fad44d690a9e061c9cc560f2cf078d1 /app-vim
parentapp-vim/uptime: Clean up old. (diff)
downloadgentoo-bbd410a7dbce30963a0d36a354cb3bdf02f07399.tar.gz
gentoo-bbd410a7dbce30963a0d36a354cb3bdf02f07399.tar.bz2
gentoo-bbd410a7dbce30963a0d36a354cb3bdf02f07399.zip
app-vim/info: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/info/info-1.7-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/info/info-1.7-r2.ebuild b/app-vim/info/info-1.7-r2.ebuild
new file mode 100644
index 000000000000..2c3e36887c7e
--- /dev/null
+++ b/app-vim/info/info-1.7-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: GNU info documentation browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=21"
+LICENSE="BSD"
+KEYWORDS="~x86 ~alpha ~sparc ~ia64 ~ppc ~s390 ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT="This plugin adds the :Info command."
+
+src_prepare() {
+ default
+
+ # The 'h' key is a bad choice for help. 'H' would have been a
+ # much better choice. I sent this suggestion to the maintainer,
+ # but no reply.
+ sed -i 's/\(noremap <buffer> \)h/\1H/' plugin/info.vim || die 'sed failed'
+}