summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-25 23:13:39 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-26 00:13:22 +0100
commitec7b9964a7d3565ef6a48bdcdc55345d841cc4e4 (patch)
tree4441234fe9b2aec7dae09d060d0c647b86ce8377 /app-vim
parentx11-wm/xpra: Add USE=webcam. (diff)
downloadgentoo-ec7b9964a7d3565ef6a48bdcdc55345d841cc4e4.tar.gz
gentoo-ec7b9964a7d3565ef6a48bdcdc55345d841cc4e4.tar.bz2
gentoo-ec7b9964a7d3565ef6a48bdcdc55345d841cc4e4.zip
app-vim/enhancedcommentify: stable for amd64. mark stable across the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.3-r1.ebuild20
-rw-r--r--app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch4
-rw-r--r--app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch4
3 files changed, 12 insertions, 16 deletions
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.3-r1.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.3-r1.ebuild
index 2810177c2cd0..5b27c1742d7a 100644
--- a/app-vim/enhancedcommentify/enhancedcommentify-2.3-r1.ebuild
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.3-r1.ebuild
@@ -1,32 +1,28 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit vim-plugin eutils
+inherit vim-plugin
DESCRIPTION="vim plugin: enhanced comment creation"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=23"
LICENSE="BSD"
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
-IUSE=""
+KEYWORDS="alpha amd64 ia64 mips ppc sparc x86"
VIM_PLUGIN_HELPFILES="EnhancedCommentify"
-DEPEND="
- >=sys-apps/sed-4"
+DEPEND="sys-apps/sed"
# See bug #74897.
RDEPEND="
${DEPEND}
!app-vim/ctx"
-src_prepare() {
- default
-
+PATCHES=(
# See bug #79185.
- epatch "${FILESDIR}"/${PN}-2.1-gentooisms.patch
- epatch "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
-}
+ "${FILESDIR}"/${PN}-2.1-gentooisms.patch
+ "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
+)
diff --git a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch
index 597518a6d547..7c350a5310e5 100644
--- a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch
+++ b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch
@@ -1,5 +1,5 @@
---- plugin/EnhancedCommentify.vim.orig 2005-03-01 02:28:23.409962824 -0500
-+++ plugin/EnhancedCommentify.vim 2005-03-01 02:29:45.695453528 -0500
+--- a/plugin/EnhancedCommentify.vim 2005-03-01 02:28:23.409962824 -0500
++++ b/plugin/EnhancedCommentify.vim 2005-03-01 02:29:45.695453528 -0500
@@ -740,7 +740,9 @@
\ 'psf\|ptcap\|r\|radiance\|ratpoison\|readline\remind\|'.
\ 'ruby\|screen\|sed\|sm\|snnsnet\|snnspat\|snnsres\|spec\|'.
diff --git a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch
index 9e45142ff8ae..a22b30ebcf31 100644
--- a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch
+++ b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch
@@ -1,5 +1,5 @@
---- plugin/EnhancedCommentify.vim.orig 2005-01-27 00:20:00.049461056 -0500
-+++ plugin/EnhancedCommentify.vim 2005-01-27 00:17:57.617073608 -0500
+--- a/plugin/EnhancedCommentify.vim 2005-01-27 00:20:00.049461056 -0500
++++ b/plugin/EnhancedCommentify.vim 2005-01-27 00:17:57.617073608 -0500
@@ -628,6 +628,10 @@
" letter.
if match(synFiletype, '\l\+\u') == 0