summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 23:09:37 +0100
committerSam James <sam@gentoo.org>2021-04-19 23:41:28 +0100
commitf98195b7acbaabf1c29e1932ed2fbbeea1df870a (patch)
tree93ce67559d5f695a946ac76ab2e68284b4f39f6d /app-vim
parentapp-cdr/mp3burn: port to EAPI 7 (diff)
downloadgentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.tar.gz
gentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.tar.bz2
gentoo-f98195b7acbaabf1c29e1932ed2fbbeea1df870a.zip
app-vim/taglist: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/taglist/files/taglist-3.4-ebuilds.patch4
-rw-r--r--app-vim/taglist/taglist-4.6.ebuild11
2 files changed, 8 insertions, 7 deletions
diff --git a/app-vim/taglist/files/taglist-3.4-ebuilds.patch b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
index 8fcc928d4497..51b1a2435e59 100644
--- a/app-vim/taglist/files/taglist-3.4-ebuilds.patch
+++ b/app-vim/taglist/files/taglist-3.4-ebuilds.patch
@@ -1,5 +1,5 @@
---- taglist-3.4/plugin/taglist.vim.orig 2004-10-02 00:12:58.400215576 +0100
-+++ taglist-3.4/plugin/taglist.vim 2004-10-02 00:26:28.535056360 +0100
+--- a/plugin/taglist.vim
++++ b/plugin/taglist.vim
@@ -205,6 +205,9 @@
let s:tlist_def_cobol_settings = 'cobol;d:data;f:file;g:group;p:paragraph;' .
\ 'P:program;s:section'
diff --git a/app-vim/taglist/taglist-4.6.ebuild b/app-vim/taglist/taglist-4.6.ebuild
index 9d03fdf679f7..80f6a853fddb 100644
--- a/app-vim/taglist/taglist-4.6.ebuild
+++ b/app-vim/taglist/taglist-4.6.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit vim-plugin epatch
+inherit vim-plugin
DESCRIPTION="vim plugin: ctags-based source code browser"
HOMEPAGE="http://vim-taglist.sourceforge.net/"
+
LICENSE="vim"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
@@ -14,6 +15,6 @@ RDEPEND="dev-util/ctags"
VIM_PLUGIN_HELPFILES="${PN}.txt"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.4-ebuilds.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-ebuilds.patch
+)