summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-04-17 21:10:28 +0200
committerUlrich Müller <ulm@gentoo.org>2018-04-17 21:11:56 +0200
commit1814be0eb8a7a1572bdf4fdbcfcb2f5ee264fa63 (patch)
treede3fda609246b182bc2504accdb488aa8800930b /app-xemacs/ebuild-mode
parentapp-emacs/ebuild-mode: Version bump. (diff)
downloadgentoo-1814be0eb8a7a1572bdf4fdbcfcb2f5ee264fa63.tar.gz
gentoo-1814be0eb8a7a1572bdf4fdbcfcb2f5ee264fa63.tar.bz2
gentoo-1814be0eb8a7a1572bdf4fdbcfcb2f5ee264fa63.zip
app-xemacs/ebuild-mode: Version bump.
Package-Manager: Portage-2.3.29, Repoman-2.3.9
Diffstat (limited to 'app-xemacs/ebuild-mode')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index 72e9a5e11582..7e83220e4780 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1 +1,2 @@
DIST ebuild-mode-1.42.tar.xz 34936 BLAKE2B dd94d17dc57e2d32b329ab62ec6eec8ada6a4aeddadb8d978736f5dcb4d613759fd860043cab92d12db11614f8b7fa71fc5537576a2af3f5e6c9d56fc2fdcc05 SHA512 119f954eaf009bd0c9f0a75810b94a54d65ed91c6ffef20dd164c7a5ef095410dd0f3642426817f5efa6623d4f3e120ed3b27076222b02a90e75a83bb80b8703
+DIST ebuild-mode-1.43.tar.xz 34688 BLAKE2B 577900e2fa7ccb2362ec7f9046affb58e92bdfde44f2ea48274ba61d65f35fa6a1852bda6d9c64bd3f63aba99df244b4cb3378de079259508b149cdacf7caf28 SHA512 91f9a06de6feeeadb27d765a6ca6f2fa17e01938a6c953efe3586646f1bf48da87fe269ee9b07b2e16199d3ba4a76f42b8be9143218b808fac2971fc6f64f36d
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild
new file mode 100644
index 000000000000..1288c724a3a0
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.43.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xemacs-elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile ebuild-mode.el gentoo-newsitem-mode.el || die
+ xemacs-elisp-make-autoload-file \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}