summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-12-28 11:00:23 +0100
committerUlrich Müller <ulm@gentoo.org>2021-12-28 11:00:23 +0100
commitf1a0b67099a4e1439b6f4d491c96e5862d4cf27f (patch)
tree12f240f6a3b3d881cf1233f2ae55b1d1ce448e6a /app-xemacs/ebuild-mode
parentapp-emacs/ebuild-mode: Version bump to 1.54 (diff)
downloadgentoo-f1a0b67099a4e1439b6f4d491c96e5862d4cf27f.tar.gz
gentoo-f1a0b67099a4e1439b6f4d491c96e5862d4cf27f.tar.bz2
gentoo-f1a0b67099a4e1439b6f4d491c96e5862d4cf27f.zip
app-xemacs/ebuild-mode: Version bump to 1.54
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs/ebuild-mode')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.54.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index c6cb5ae44a34..506e42c0855e 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.51.tar.xz 35280 BLAKE2B 63f57919bb73937ce3d40b4d6762e78c78d273bcf67875434d12450e00632d457d3dedbe6f213c1979a60cbc0a0874723e3e9424fdcfb64a48acc885cc90e577 SHA512 ff9ece96fbe7bfc9c070769dc6667e8c33f8fb7ef20a2d347c670342ef7500b52b54a93ed37ac9ea13a89c1b89752f5dd6e56c234abe9a4fcd4eb6bad0d0b466
DIST ebuild-mode-1.53.tar.xz 35920 BLAKE2B ee932441e23ba4b876e98feb9ff9dfea2e395296846e14f776ac10f4c5bab6b711161b4c890b0d8f2ccb5749db5bced3f693aa172e3ae92af506fee26fb5750a SHA512 8fcc28139c0cace21159a0b5026573f401f65b4501ff888f9818d8f5a506a7bc1f8d8a133f775619efc9e16e2172d6b5daba539b4e38b1a378c0b35395263ef9
+DIST ebuild-mode-1.54.tar.xz 35768 BLAKE2B 8cfba7230eb61bcdede498c696aedd7c64d01e5a1e7a22ad0edf793fbf6970bddd818d431e717bcc0b5ea07d35b525468131df260206db912f36341947b98d08 SHA512 7e67f3875beb42bc94fe522364212a02ea93e11aa1a64512283ab783c5a41097076b29a3ecf72b4369180253efd26fd3a223d617909953b2c7626f5cbc2aaba1
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.54.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.54.ebuild
new file mode 100644
index 000000000000..417a5874359c
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.54.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ local XEMACS="${EPREFIX}/usr/bin/xemacs"
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_install() {
+ insinto /usr/share/xemacs/site-packages/lisp/${PN}
+ doins *.el *.elc
+}