summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-07-21 22:35:50 +0200
committerUlrich Müller <ulm@gentoo.org>2020-07-21 22:36:26 +0200
commit4121bca78a6adaef0da4591598caeabcc545e134 (patch)
treefd306276bd5fd938bc957d9a0d7ea2c88f65d7d9 /app-xemacs
parentdev-perl/libintl-perl: Drop x64-cygwin re bug #690140 (diff)
downloadgentoo-4121bca78a6adaef0da4591598caeabcc545e134.tar.gz
gentoo-4121bca78a6adaef0da4591598caeabcc545e134.tar.bz2
gentoo-4121bca78a6adaef0da4591598caeabcc545e134.zip
app-xemacs/ebuild-mode: Version bump to 1.51.
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.51.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index b2bef5bb7f05..e6480fe3159d 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1 +1,2 @@
DIST ebuild-mode-1.50.tar.xz 35440 BLAKE2B 281719a0a686ef1c80c8391cc118d14085ac6407dee5ee7ee44229bb529de041d31fcec7c08bb1e4b8b5057823c5d99a49a9786daa0b7b17a766155b7daaaecc SHA512 a7c232103848c7782a4ebad89e064f3bc37a78427228be799d8e1bd3670524b32050229ba7cd48d9e4c2b0bb32828ce95eb2e47038411591d03fa8f998614c1e
+DIST ebuild-mode-1.51.tar.xz 35280 BLAKE2B 63f57919bb73937ce3d40b4d6762e78c78d273bcf67875434d12450e00632d457d3dedbe6f213c1979a60cbc0a0874723e3e9424fdcfb64a48acc885cc90e577 SHA512 ff9ece96fbe7bfc9c070769dc6667e8c33f8fb7ef20a2d347c670342ef7500b52b54a93ed37ac9ea13a89c1b89752f5dd6e56c234abe9a4fcd4eb6bad0d0b466
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.51.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.51.ebuild
new file mode 100644
index 000000000000..e3cf9789dead
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.51.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ local XEMACS="${EPREFIX}/usr/bin/xemacs"
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ "${XEMACS}" -batch -q --no-site-file \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_install() {
+ insinto /usr/share/xemacs/site-packages/lisp/${PN}
+ doins *.el *.elc
+}