summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-11-24 08:44:56 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-11-24 08:45:24 +0100
commitf2a7862b553990e109332722c9451974725c30de (patch)
treeb9750e1aa9c56896b5ab48ff0c3546b961b9f414 /dev-ada/e3-core
parentapp-emulation/xen: remove unused 'multilib' eclass (diff)
downloadgentoo-f2a7862b553990e109332722c9451974725c30de.tar.gz
gentoo-f2a7862b553990e109332722c9451974725c30de.tar.bz2
gentoo-f2a7862b553990e109332722c9451974725c30de.zip
dev-ada/e3-core: add dep & fix LDFLAGS
Closes: https://bugs.gentoo.org/827006 Closes: https://bugs.gentoo.org/827026 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/e3-core')
-rw-r--r--dev-ada/e3-core/e3-core-22.1.0.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-ada/e3-core/e3-core-22.1.0.ebuild b/dev-ada/e3-core/e3-core-22.1.0.ebuild
index cb872478e007..a5c6291d6ee6 100644
--- a/dev-ada/e3-core/e3-core-22.1.0.ebuild
+++ b/dev-ada/e3-core/e3-core-22.1.0.ebuild
@@ -13,7 +13,8 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/colorama
dev-python/stevedore
@@ -23,8 +24,11 @@ DEPEND="${RDEPEND}
dev-python/requests-toolbelt
dev-python/httpretty
dev-vcs/subversion
+ dev-python/tqdm
+ dev-python/tomlkit
)"
BDEPEND=""
+REQUIRED_USE="x86? ( !test )"
PATCHES=(
"${FILESDIR}"/${P}-distro.patch
@@ -38,14 +42,8 @@ src_prepare() {
}
src_compile() {
- local PLATFORM
- if use amd64; then
- PLATFORM=x86_64-linux
- else
- PLATFORM=x86-linux
- fi
-
+ local PLATFORM=x86_64-linux
rm src/e3/os/data/rlimit* || die
- $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
distutils-r1_src_compile
}