summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/glade
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/glade')
-rw-r--r--dev-ada/glade/Manifest1
-rw-r--r--dev-ada/glade/glade-2006.0.ebuild96
-rw-r--r--dev-ada/glade/metadata.xml5
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-ada/glade/Manifest b/dev-ada/glade/Manifest
new file mode 100644
index 000000000000..ec9dd6570ade
--- /dev/null
+++ b/dev-ada/glade/Manifest
@@ -0,0 +1 @@
+DIST glade-2006.0.tar.bz2 393969 SHA256 0a0ef4b7aeb426b4b298b38fcdb9d7236b56a9c5aa6d16c24745450587b6ef85 SHA512 eb35f0ea13b415cf5a17d0b175bf395079d90640a69d9d3ace30df5feaa19618f2cb2dfbd70c1da9dd420c34717e015cec632675772a11faeb8aaf14644eab40 WHIRLPOOL ff141503f9f9199d128811aaaf168c6e82b5a1f3bd3c3e44e79d8be7aa65f838de4d942a2a1b57deb9fa438fd24ed02420ea8c03fe5f7881742b4d71881050ff
diff --git a/dev-ada/glade/glade-2006.0.ebuild b/dev-ada/glade/glade-2006.0.ebuild
new file mode 100644
index 000000000000..c59d856c7291
--- /dev/null
+++ b/dev-ada/glade/glade-2006.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="An implementation of the Distributed Systems Annex for the GNAT compiler"
+HOMEPAGE="http://libre2.adacore.com/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="=virtual/ada-1995*"
+RDEPEND="${DEPEND}"
+
+# temporary install pool
+DN="${WORKDIR}/LocalD"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # configure performs some stupid check and in a wrong way, we will surely
+ # have a modern enough gnat
+ sed -i -e "s:-le \"\$am_gnatls_date\":-le \"20040909\":" configure
+}
+
+lib_compile()
+{
+ econf --with-optimization="${CFLAGS}" || die "econf failed"
+ emake || die "make failed"
+ einfo "lib_compile completed"
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install()
+{
+ # This package expands the libs and sources provided by compiler. Therefore
+ # we install in yet another local location, to bypass gnat's automation.
+ # The compiler specific stuf is then moved to ${D} directly. Not ideal, as
+ # this hook is called from within src_compile, but alternatives are more
+ # complex. The next version should probably be done mirroring the asis-xxx.
+ make prefix="${DN}" \
+ bindir="${DN}"/$(get_gnat_value PATH) \
+ install || die "make install failed"
+ #
+ # Makefile does not seem to accept much more than bindir, so the rest we
+ # will move manually
+ local Gnat_Libdir=$(get_gnat_value ADA_OBJECTS_PATH)
+ local Gnat_Incdir=$(get_gnat_value ADA_INCLUDE_PATH)
+ mkdir -p "${DN}/${Gnat_Libdir}"
+ mv "${DN}/lib/garlic"/*.ali "${DN}/lib/garlic"/libgarlic.a "${DN}/${Gnat_Libdir}"
+
+ mkdir -p "${DN}/${Gnat_Incdir}"
+ mv "${DN}/lib/garlic"/*.ad? "${DN}/${Gnat_Incdir}"
+ rm -rf "${DN}/lib"
+
+ # remove files already provided by compiler
+ pushd "${DN}"
+ for fn in "${Gnat_Libdir:1}"/*.ali "${Gnat_Incdir:1}"/*.ad?; do
+ # Gnat_Lib/Incdir are global, need to remove leading /
+ if [[ -e /${fn} ]]; then
+ rm -f ${fn}
+ fi
+ done
+ popd
+}
+
+src_install ()
+{
+ # library is installed into the corresponding gnat, no extra env setting
+ # necessary
+ echo "" > ${LibEnv}
+
+ gnat_src_install
+
+ # clean empty dirs
+ rm -rf "${D}"/usr/share/gnat/ "${D}"/usr/lib/ada/
+
+ # move prepared stuff over
+ cp -rp "${DN}"/* "${D}"
+ dodoc README NEWS
+ insinto /usr/share/doc/${PF}
+ doins -r Examples/
+}
+
+pkg_postinst() {
+ echo
+ elog "GLADE has been installed at the gnat compiler location, expanding System Library."
+ elog "No further configuration is necessary. Enjoy."
+ echo
+}
diff --git a/dev-ada/glade/metadata.xml b/dev-ada/glade/metadata.xml
new file mode 100644
index 000000000000..aec150231c3f
--- /dev/null
+++ b/dev-ada/glade/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+</pkgmetadata>