summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/xmlada
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/xmlada')
-rw-r--r--dev-ada/xmlada/Manifest2
-rw-r--r--dev-ada/xmlada/metadata.xml6
-rw-r--r--dev-ada/xmlada/xmlada-1.0-r4.ebuild97
-rw-r--r--dev-ada/xmlada/xmlada-2.2.0-r1.ebuild103
-rw-r--r--dev-ada/xmlada/xmlada-2.2.0.ebuild70
5 files changed, 278 insertions, 0 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
new file mode 100644
index 000000000000..04ee3943bc02
--- /dev/null
+++ b/dev-ada/xmlada/Manifest
@@ -0,0 +1,2 @@
+DIST XmlAda-1.0.tgz 322079 SHA256 e86ccd448574ff1ec2205f9bfbfa5812023dc4ce5d4b1c2e2c8b1ffbd29ce917 SHA512 2b692d5bf1e1c28a303cee42fa43d9f5dc578aa5c93134ae25f3abe04ab3b6c3d5744ea0aa28d1dff0fc82fb190d1e60a1c8d6cd2866989b0cd63c2af438126b WHIRLPOOL 21db8cdb9432848a69b8abe2ebcc152be37876b28387e4922fc56f72190fcc9da791a9b87f1736aaaec9b4962aa28df46614ef3731eec8711d418583ff383a00
+DIST xmlada-2.2.0.tar.bz2 591666 SHA256 3935a1a158a120bb53d5417a518b7283b5d97f478cf3af0f5e02222ae3b5c7b4 SHA512 dc8e1c963f4d40518be1058972697ea629a065e709704b05d501e62be77733f00419d9578fcc1305d3fbc5b90dae1742e7c2ae2ae0e3803c47e767e57770872a WHIRLPOOL c3cd616301b8be9f126f55f3a069a34974a80d3753839b8c8745edfb96b86ef3d77ae009689e881f56c9f938fa1c62f3d86a6d9a4222a661e3f43c9077911af4
diff --git a/dev-ada/xmlada/metadata.xml b/dev-ada/xmlada/metadata.xml
new file mode 100644
index 000000000000..66f2f1fc397f
--- /dev/null
+++ b/dev-ada/xmlada/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>XML/Ada includes a complete XML parser that fully supports the XML 1.0 specifications, including DTDs, entity resolution, external entities,attribute normalization, and conditional sections. XML/Ada also supports the SAX 2.0 standard. Through an object-oriented Ada interface, the XML/Ada SAX implementation provides an extremely efficient way to convert XML streams to application-specific data representations. XML/Ada includes full support for the core part of DOM 2.0. In addition to this XML support, XML/Ada includes an extensive set of packages to read, manipulate and write Unicode streams, in various encodings like UTF-8, UTF-16 and UTF-32. It provides a conversion mechanism between Unicode and encodings such as Latin-1, Latin-2, etc.</longdescription>
+</pkgmetadata>
diff --git a/dev-ada/xmlada/xmlada-1.0-r4.ebuild b/dev-ada/xmlada/xmlada-1.0-r4.ebuild
new file mode 100644
index 000000000000..592676f940e4
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-1.0-r4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat versionator
+
+IUSE=""
+
+Name="XmlAda"
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre2.adacore.com/xmlada/"
+SRC_URI="https://libre2.adacore.com/xmlada/${Name}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/gnat
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd "${S}"
+ #making .dvi docs is problemmatic. Skip that for now
+ sed -i -e "s/all: obj test docs/all: obj test/" Makefile.in
+ #increase stack size
+ cd sax
+ sed -i -e "s/Stack_Size : constant Natural := 64;/Stack_Size : constant Natural := 128;/" sax-readers.adb
+}
+
+lib_compile()
+{
+ # for some reason shared libs are assigned version numbers from some
+ # pre-release (possibly when upstream stopped to care about them?)
+ local MAJOR=$(get_major_version)
+ local MINOR=$(get_version_component_range 2-)
+ # force building shared libs and fix broken shared lib versioning
+ sed -i -e "s:BUILD_SHARED=FALSE:BUILD_SHARED=TRUE:" \
+ -e "s:libxmlada_\${@\:%_install=%}-\${MAJOR}.\${MINOR}.so:libxmlada_\${@\:%_inst=%}.so.${MAJOR}.${MINOR}:" \
+ -e "s:libxmlada_\${@\:%_inst=%}-\${MAJOR}.\${MINOR}.so:libxmlada_\${@\:%_inst=%}.so.${MAJOR}.${MINOR}:" \
+ -e "s:FPIC=:FPIC=-fPIC:" Makefile.in
+
+ export CFLAGS=$ADACFLAGS
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --with-system-zlib || die
+
+ export COMPILER=gnatmake
+ make || die "make failed"
+}
+
+# here we need to use the $1 - passed gnat profile name
+lib_install() {
+ make PREFIX="${DL}" install || die "install failed"
+
+ # fix xmlada-config hardsets locations
+ sed -i -e "s:\${prefix}/include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ -e "s:\${prefix}/lib:${AdalibLibTop}/$1/${PN}:g" \
+ "${DL}"/bin/xmlada-config
+
+ # now move stuff to proper location and delete extras
+ mv "${DL}"/bin/xmlada-config "${DL}"/lib/* "${DL}"/include/${PN}/*.ali "${DL}"
+ rm -rf "${DL}"/bin "${DL}"/include "${DL}"/lib
+}
+
+src_install ()
+{
+ cd "${S}"
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins dom/*.ad? input_sources/*.ad? sax/*.ad? unicode/*.ad?
+
+ #set up environment
+ echo "PATH=%DL%" > ${LibEnv}
+ echo "LDPATH=%DL%" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc AUTHORS README docs/xml.ps
+ dohtml docs/*.html
+ doinfo docs/*.info
+ #need to give a proper name to the info file
+ cd "${D}"/usr/share/info
+ mv xml.info.gz ${PN}.info.gz
+
+}
diff --git a/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild b/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..3ab0747376b4
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2.2.0-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat versionator
+
+IUSE=""
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.adacore.com/xmlada/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/ada
+ virtual/latex-base
+ sys-apps/texinfo
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # adjusting profile independent stuff in project files
+# for fn in distrib/*/xmlada*.gpr; do
+# sed -i -e "s:../../include/xmlada:${AdalibSpecsDir}/${PN}:" ${fn}
+# done
+ sed -i -e "s:\.\./\.\./include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ distrib/*/xmlada*.gpr || die "failed to adjust project files"
+
+ # fix profile independent stuff in xmlada-config
+ sed -i -e "s:\${prefix}/include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ xmlada-config.in || die "failed to adjust xmlada-config"
+
+ # doinfo changed from gzipping stuff to bzipping, so we better rename the
+ # file before calling it to guard against other possible changes
+ mv docs/xml.info docs/${PN}.info
+}
+
+lib_compile()
+{
+ econf
+ emake
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install() {
+ # bug #283160
+ emake -j1 PREFIX="${DL}" install || die "install failed"
+
+ pushd "${DL}"
+ # fix xmlada-config hardsets locations and move it to proper location
+ sed -i -e "s:\${prefix}/lib/xmlada:${AdalibLibTop}/$1/${PN}:" \
+ -e "s:\${prefix}/lib:${AdalibLibTop}/$1/${PN}:g" \
+ bin/xmlada-config
+ mv bin/xmlada-config "${DLbin}"
+
+ # sed and organize gpr files
+ sed -i -e "s:\.\./xmlada:${AdalibLibTop}/$1/${PN}:" "${DL}"/lib/gnat/*.gpr
+ mv lib/gnat/* "${DLgpr}"
+
+ # the library and *.ali
+ mv lib/${PN}/* .
+ rm -rf bin include share lib
+
+ # fix the .so links
+ rm *.so
+ for fn in *.so.* ; do
+ ln -s ${fn} ${fn%so*}so
+ done
+ popd
+}
+
+src_install ()
+{
+ cd "${S}"
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins dom/*.ad? input_sources/*.ad? sax/*.ad? unicode/*.ad? schema/*.ad?
+
+ #set up environment
+ echo "PATH=%DLbin%" > ${LibEnv}
+ echo "LDPATH=%DL%" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}" >> ${LibEnv}
+ echo "ADA_PROJECT_PATH=%DLgpr%" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc AUTHORS README TODO features
+ dohtml docs/*.html
+ doinfo docs/*.info
+ insinto /usr/share/doc/${PF}
+ doins docs/*.pdf distrib/xmlada_gps.py
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r docs/{dom,sax,schema}
+}
diff --git a/dev-ada/xmlada/xmlada-2.2.0.ebuild b/dev-ada/xmlada/xmlada-2.2.0.ebuild
new file mode 100644
index 000000000000..77705b4f55e9
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-2.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat versionator
+
+IUSE=""
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.adacore.com/xmlada/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/ada
+ virtual/latex-base
+ sys-apps/texinfo
+ >=sys-apps/sed-4"
+RDEPEND=""
+
+lib_compile()
+{
+ econf || die "econf failed"
+ emake || die "make failed"
+}
+
+# NOTE: we are using $1 - the passed gnat profile name
+lib_install() {
+ make PREFIX="${DL}" install || die "install failed"
+
+ # fix xmlada-config hardsets locations
+ sed -i -e "s:\${prefix}/include/xmlada:${AdalibSpecsDir}/${PN}:" \
+ -e "s:\${prefix}/lib/xmlada:${AdalibLibTop}/$1/${PN}/lib:" \
+ -e "s:\${prefix}/lib:${AdalibLibTop}/$1/${PN}/lib:g" \
+ "${DL}"/bin/xmlada-config
+
+ # now move stuff to proper location and delete extras
+# mv "${DL}"/bin/xmlada-config "${DL}"/lib/* "${DL}"/include/${PN}/*.ali "${DL}"
+ rm -rf "${DL}"/include "${DL}"/share
+}
+
+src_install ()
+{
+ cd "${S}"
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins dom/*.ad? input_sources/*.ad? sax/*.ad? unicode/*.ad? schema/*.ad?
+
+ #set up environment
+ echo "PATH=%DL%/bin" > ${LibEnv}
+ echo "LDPATH=%DL%/lib" >> ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%/lib" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc AUTHORS README TODO features
+ dohtml docs/*.html
+ doinfo docs/*.info
+ # give a proper name to the info file
+ mv "${D}"/usr/share/info/xml.info.gz "${D}"/usr/share/info/${PN}.info.gz
+ insinto /usr/share/doc/${PF}
+ doins docs/*.pdf distrib/xmlada_gps.py
+
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r docs/{dom,sax,schema}
+}