summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-14 22:26:38 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-14 22:27:13 +0100
commit865a4cc03e13a7711805478a1d69de846490e05d (patch)
tree3bca0403f1d56a7b983c757d86127dc38517689e /dev-ada/xmlada
parentapp-arch/dpkg: add 1.21.18 (diff)
downloadgentoo-865a4cc03e13a7711805478a1d69de846490e05d.tar.gz
gentoo-865a4cc03e13a7711805478a1d69de846490e05d.tar.bz2
gentoo-865a4cc03e13a7711805478a1d69de846490e05d.zip
dev-ada/xmlada: stabilize new and remove old
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/xmlada')
-rw-r--r--dev-ada/xmlada/Manifest1
-rw-r--r--dev-ada/xmlada/xmlada-2021-r1.ebuild81
-rw-r--r--dev-ada/xmlada/xmlada-2021-r2.ebuild94
-rw-r--r--dev-ada/xmlada/xmlada-22.0.0.ebuild4
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0.ebuild4
5 files changed, 4 insertions, 180 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index c19e64ea2727..0ebf7605be8a 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -1,3 +1,2 @@
-DIST xmlada-2021-20210518-19D50-src.tar.gz 1555951 BLAKE2B 589815d4781471a48d3bb4a12475762cb2ba8f885df8ea774f009c8be9ded41bccc414bb88a2b3d313701b0b2edefcd065fac8a13d208a7bb1679a3467a60c35 SHA512 e2fb1a87cb0cebae842f87412d0ccc8a18b20e5e2c4e3d9ad6ec3a6ae18e4e53c12efd9ea3f2515baa5bfec2b4ddee7808385cc471e3cca9b8c4be3d03093e85
DIST xmlada-22.0.0.tar.gz 1022947 BLAKE2B cea409a45a3b0c8eba48f858278d4e7129eca2e77fa749f5a761e31a81834efba67223f07c99441a9673a8f6de9a608a12cf610225ca5aee7fbde0235d9af1d9 SHA512 7e8a0cab2f4c300fe3b0d31e00d17334e36798430e49868448caa696044964464f558cffba8f35e35a58b097c968322891119b2abd9f210737ca877f0189f32e
DIST xmlada-23.0.0.tar.gz 1053370 BLAKE2B 4edf2244818d72d6fc760f60c8145f373e5445d1d245b20b605e21faa7eeefed7835db87c1fd1239008e75211a572294e1d8e35af16c2ba2631c02d1d3b6f52f SHA512 a0fb2a34ffb5edf408fbdc1a3d68511b5545a5ec8993251ba75d71dd2a197f14e187d08f8febd71cb23bbd694889a99941911386af8468c5eb3b11128555edcb
diff --git a/dev-ada/xmlada/xmlada-2021-r1.ebuild b/dev-ada/xmlada/xmlada-2021-r1.ebuild
deleted file mode 100644
index e39fcd732fd4..000000000000
--- a/dev-ada/xmlada/xmlada-2021-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 )
-inherit ada multiprocessing
-
-MYP=${P}-${PV}0518-19D50-src
-ID=6a2cf72f308cc787926b12ddc20993fcf2b8ea79
-ADAMIRROR=https://community.download.adacore.com/v1
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2019-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- emake test
- emake run_test | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- rm -f "${D}"/usr/share/doc/${PN}/.buildinfo
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- dodir /usr/share/gnatdoc
- mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/gnatdoc/ || die
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}
diff --git a/dev-ada/xmlada/xmlada-2021-r2.ebuild b/dev-ada/xmlada/xmlada-2021-r2.ebuild
deleted file mode 100644
index d4925f5ba896..000000000000
--- a/dev-ada/xmlada/xmlada-2021-r2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 )
-inherit ada multiprocessing
-
-MYP=${P}-${PV}0518-19D50-src
-ID=6a2cf72f308cc787926b12ddc20993fcf2b8ea79
-ADAMIRROR=https://community.download.adacore.com/v1
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2019-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -XTESTS_ACTIVATED=Only \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- emake --no-print-directory -C tests tests | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- rm -f "${D}"/usr/share/doc/${PN}/.buildinfo
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- dodir /usr/share/gnatdoc
- mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/gnatdoc/ || die
- rm -f "${D}"/usr/share/examples/xmlada/*/b__*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
- rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
- rm -f "${D}"/usr/share/examples/xmlada/*/*.o
- rm -f "${D}"/usr/share/examples/xmlada/*/*example
- rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
- rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}
diff --git a/dev-ada/xmlada/xmlada-22.0.0.ebuild b/dev-ada/xmlada/xmlada-22.0.0.ebuild
index 21d209e6354d..91c12a5c5d1e 100644
--- a/dev-ada/xmlada/xmlada-22.0.0.ebuild
+++ b/dev-ada/xmlada/xmlada-22.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
${ADA_REQUIRED_USE}"
diff --git a/dev-ada/xmlada/xmlada-23.0.0.ebuild b/dev-ada/xmlada/xmlada-23.0.0.ebuild
index 72b36a303116..60a27cd43583 100644
--- a/dev-ada/xmlada/xmlada-23.0.0.ebuild
+++ b/dev-ada/xmlada/xmlada-23.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
${ADA_REQUIRED_USE}"