summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-21 07:56:26 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-21 07:57:20 +0100
commitd377d74ec17c3aee91156505f9701239ad088def (patch)
treec96468e5fc55e8ec076cfd9d6fa9918bfe1d95a7 /dev-ada
parentdev-python/zc-lockfile: Use PYPI_PN (diff)
downloadgentoo-d377d74ec17c3aee91156505f9701239ad088def.tar.gz
gentoo-d377d74ec17c3aee91156505f9701239ad088def.tar.bz2
gentoo-d377d74ec17c3aee91156505f9701239ad088def.zip
dev-ada/xmlada: stabilize all and remove old
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0-r1.ebuild2
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0.ebuild86
2 files changed, 1 insertions, 87 deletions
diff --git a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild b/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
index 67a8de7968c3..328b20e285c9 100644
--- a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
+++ b/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+shared static-libs static-pic"
REQUIRED_USE="|| ( shared static-libs static-pic )
${ADA_REQUIRED_USE}"
diff --git a/dev-ada/xmlada/xmlada-23.0.0.ebuild b/dev-ada/xmlada/xmlada-23.0.0.ebuild
deleted file mode 100644
index 6b274fccb9df..000000000000
--- a/dev-ada/xmlada/xmlada-23.0.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 gcc_12_2_0 )
-inherit ada multiprocessing
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -XTESTS_ACTIVATED=Only \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- emake --no-print-directory -C tests tests | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- rm -f "${D}"/usr/share/examples/xmlada/*/b__*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
- rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
- rm -f "${D}"/usr/share/examples/xmlada/*/*.o
- rm -f "${D}"/usr/share/examples/xmlada/*/*example
- rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
- rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}