summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-05-22 12:40:13 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-05-22 12:40:13 +0200
commitf2da2047db041bbe2a18af7a7a58fc3f66c8323b (patch)
treeae7ab2ff04925a0d9ef829e0b0a5ce82bcd5c653 /dev-ada
parentsys-kernel/vanilla-sources: Linux bumps (diff)
downloadgentoo-f2da2047db041bbe2a18af7a7a58fc3f66c8323b.tar.gz
gentoo-f2da2047db041bbe2a18af7a7a58fc3f66c8323b.tar.bz2
gentoo-f2da2047db041bbe2a18af7a7a58fc3f66c8323b.zip
dev-ada/gnatcoll-core: enable gnat_2020, fix VariableScope
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild74
-rw-r--r--dev-ada/gnatcoll-core/gnatcoll-core-2020.ebuild10
2 files changed, 79 insertions, 5 deletions
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild
new file mode 100644
index 000000000000..625f0692fdc0
--- /dev/null
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2020-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ADA_COMPAT=( gnat_201{6,7,8,9} gnat_2020 )
+inherit ada multiprocessing
+
+MYP=${P}-20200429-19B7C
+
+DESCRIPTION="GNAT Component Collection Core packages"
+HOMEPAGE="http://libre.adacore.com"
+SRC_URI="https://community.download.adacore.com/v1/c94f2ac914cb305f6bef174329fa0b5003d84935?filename=${MYP}-src.tar.gz
+ -> ${MYP}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared static-libs static-pic"
+
+RDEPEND="
+ >=dev-ada/libgpr-2020[${ADA_USEDEP},shared?,static-libs?,static-pic?]
+"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[${ADA_USEDEP}]"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@GNATLS@:${GNATLS}:g" \
+ src/gnatcoll-projects.ads \
+ || die
+}
+
+src_configure() {
+ emake setup
+}
+
+src_compile() {
+ build () {
+ gprbuild -p -m -j$(makeopts_jobs) \
+ -XBUILD=PROD -v -XGNATCOLL_VERSION=${PV} \
+ -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$* -XGPR_BUILD=$1 \
+ gnatcoll.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
+ }
+ if use shared; then
+ build relocatable
+ fi
+ if use static-pic; then
+ build static-pic
+ fi
+ if use static-libs; then
+ build static
+ fi
+}
+
+src_install() {
+ if use shared; then
+ emake prefix="${D}"/usr install-relocatable
+ fi
+ if use static-pic; then
+ emake prefix="${D}"/usr install-static-pic
+ fi
+ if use static-libs; then
+ emake prefix="${D}"/usr install-static
+ fi
+ rm -r "${D}"/usr/share/gpr/manifests || die
+ einstalldocs
+}
diff --git a/dev-ada/gnatcoll-core/gnatcoll-core-2020.ebuild b/dev-ada/gnatcoll-core/gnatcoll-core-2020.ebuild
index 40b7c90fb6f8..142bfee53528 100644
--- a/dev-ada/gnatcoll-core/gnatcoll-core-2020.ebuild
+++ b/dev-ada/gnatcoll-core/gnatcoll-core-2020.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,7 +38,7 @@ src_prepare() {
}
src_configure() {
- emake prefix="${D}"/usr PROCESSORS=$(makeopts_jobs) setup
+ emake setup
}
src_compile() {
@@ -61,13 +61,13 @@ src_compile() {
src_install() {
if use shared; then
- emake install-relocatable
+ emake prefix="${D}"/usr install-relocatable
fi
if use static-pic; then
- emake install-static-pic
+ emake prefix="${D}"/usr install-static-pic
fi
if use static-libs; then
- emake install-static
+ emake prefix="${D}"/usr install-static
fi
rm -r "${D}"/usr/share/gpr/manifests || die
einstalldocs