summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Buchinger <cb-gentoo@guya.de>2018-10-05 12:14:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-07 19:01:47 +0200
commit82fe59d120634e8590241a154e1329316cb1c0f3 (patch)
tree94dd32b954c68ee0c21159dd736a72dcc4a139d6 /dev-cpp/aixlog/aixlog-1.2.1.ebuild
parentdev-lua/luvit: Fix net-libs/http-parser dependency (diff)
downloadgentoo-82fe59d120634e8590241a154e1329316cb1c0f3.tar.gz
gentoo-82fe59d120634e8590241a154e1329316cb1c0f3.tar.bz2
gentoo-82fe59d120634e8590241a154e1329316cb1c0f3.zip
dev-cpp/aixlog: New package
Closes: https://bugs.gentoo.org/667794 Signed-off-by: Christian Buchinger <cb-gentoo@guya.de> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp/aixlog/aixlog-1.2.1.ebuild')
-rw-r--r--dev-cpp/aixlog/aixlog-1.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/aixlog/aixlog-1.2.1.ebuild b/dev-cpp/aixlog/aixlog-1.2.1.ebuild
new file mode 100644
index 000000000000..1246304bfa01
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}