summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-21 20:32:48 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 20:48:28 +0200
commit56dc4b75b092839d4d34f38f9a008f2802918410 (patch)
treeddeafe4588b53ab19ab9ed2f36971b1e45d98b5e /dev-cpp/asio/asio-1.10.8.ebuild
parentsys-kernel/gentoo-sources: Linux patches 3.12.64, 3.12.65 and 3.12.66 (diff)
downloadgentoo-56dc4b75b092839d4d34f38f9a008f2802918410.tar.gz
gentoo-56dc4b75b092839d4d34f38f9a008f2802918410.tar.bz2
gentoo-56dc4b75b092839d4d34f38f9a008f2802918410.zip
dev-cpp/asio: Version bump to 1.10.8
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-cpp/asio/asio-1.10.8.ebuild')
-rw-r--r--dev-cpp/asio/asio-1.10.8.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-1.10.8.ebuild b/dev-cpp/asio/asio-1.10.8.ebuild
new file mode 100644
index 000000000000..fc0aff74dbc7
--- /dev/null
+++ b/dev-cpp/asio/asio-1.10.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples ssl test"
+
+RDEPEND="dev-libs/boost
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}