summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-01-01 10:42:02 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-01-21 08:37:47 +0200
commit245ca638c0fd9d4eb3775784395fc35a335c1309 (patch)
treee29d3b83eeb28cd3de92e2e0e3a9ecf701ba8100 /dev-cpp/asio
parentsys-fs/bees: Rebased musl patch for -9999 (diff)
downloadgentoo-245ca638c0fd9d4eb3775784395fc35a335c1309.tar.gz
gentoo-245ca638c0fd9d4eb3775784395fc35a335c1309.tar.bz2
gentoo-245ca638c0fd9d4eb3775784395fc35a335c1309.zip
dev-cpp/asio: 1.18.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/18893 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.18.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 6e24c16e4339..77508e631b09 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,4 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.17.0.tar.bz2 1694631 BLAKE2B 0463355eef1714604290be43247139ea0220c5614c3c280ccf6049b64a2bb920c9eb885cf5f00c7e007caf3b049fe5cd6589dad0cb23cda4994fd31c7ecd8102 SHA512 5978cbf452aff07d6d19a2e641824628f409ab74e2e1a964776dae4c586386149acea56e4c8aa1075b247d2ce566daad640c3bbd15e211df1f73fc7b02964353
DIST asio-1.18.0.tar.bz2 1724947 BLAKE2B 6772a70c035e7df08484703b6f2fa294b6a1ade4b1e661481df0e790fe4a36d74f0f4b14023c7505fc599c4eefb3e3baf392fd7897c10c07707a0474870a6557 SHA512 4b21b72463951ffc5ef72636858955ae5af5ce0dec4c835fccf3c7e8ccfa10bd97530bfc2ec9c3f601374da8300ac2e61418845d3331c980fa9876057bbbb1e0
+DIST asio-1.18.1.tar.bz2 1729219 BLAKE2B 3f020407403175ffb6777b855a38e708241499e0fc8f1389b367bac4faf1e14b94cdf45f3b5ba64e12303237c8a3f817f7b7c320e7a58d72be6b19e04022c681 SHA512 06b41869858b69bc523564d5b219f8ebc995ca862e989f65233778c7596143075662880b6c5dd2eb24c21ba6e68a450888ab07a6bc8585bb6ede9a738e1e27c0
diff --git a/dev-cpp/asio/asio-1.18.1.ebuild b/dev-cpp/asio/asio-1.18.1.ebuild
new file mode 100644
index 000000000000..55fc4cb2fe52
--- /dev/null
+++ b/dev-cpp/asio/asio-1.18.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+# test searches for libssl during ./configure, and REQUIRED_USE is easier than
+# patching configure to not search for it with USE=-ssl
+REQUIRED_USE="test? ( ssl )"
+
+RDEPEND="dev-libs/boost:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}