summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-07-10 11:10:33 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-07-24 15:03:32 +0300
commitd1595c288ebbb12ca7ea7223481900ddfafc720c (patch)
tree93ed154d30a20aa27d73c8a5bcfd8e3f3fa62aec /dev-cpp/asio
parentdev-libs/json-c: Change USE to cpu_flags_x86_rdrand (diff)
downloadgentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.tar.gz
gentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.tar.bz2
gentoo-d1595c288ebbb12ca7ea7223481900ddfafc720c.zip
dev-cpp/asio: version 1.17.0
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/16656 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.17.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index b2528418902c..257408a9db36 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,2 +1,3 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.16.1.tar.bz2 1493978 BLAKE2B 810fd735a0cbea8e07bfe30cbf02d44469c3c7eebed3822766c0a658fe8972681232afe4a6124537886fafd0769eecc40b8eabbcaa2771b84b93cda56329394d SHA512 e8cab449887e3e362f9d3c2aa1b1bbb2f81954aeaf2cd12cefe7f848cdc30e1a576130b49f551efd49611b9d4941e724baea42739c043e158626f3c982b75311
+DIST asio-1.17.0.tar.bz2 1694631 BLAKE2B 0463355eef1714604290be43247139ea0220c5614c3c280ccf6049b64a2bb920c9eb885cf5f00c7e007caf3b049fe5cd6589dad0cb23cda4994fd31c7ecd8102 SHA512 5978cbf452aff07d6d19a2e641824628f409ab74e2e1a964776dae4c586386149acea56e4c8aa1075b247d2ce566daad640c3bbd15e211df1f73fc7b02964353
diff --git a/dev-cpp/asio/asio-1.17.0.ebuild b/dev-cpp/asio/asio-1.17.0.ebuild
new file mode 100644
index 000000000000..1a7e5378adbc
--- /dev/null
+++ b/dev-cpp/asio/asio-1.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples libressl ssl test"
+RESTRICT="!test? ( test )"
+# test searches for libssl during ./configure, and REQUIRED_USE is easier than
+# patching configure to not search for it with USE=-ssl
+REQUIRED_USE="test? ( ssl )"
+
+RDEPEND="dev-libs/boost
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}