summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-02-06 15:08:33 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 20:25:19 -0500
commit1586fed6937a88bbe2cf1949c95f1ba929d5e71a (patch)
tree1d1ab919b2390d6a81a72671e5c53e9dd6db3ba0 /dev-cpp/cairomm
parentdev-cpp/cairomm: Fix slot 1.16 (diff)
downloadgentoo-1586fed6937a88bbe2cf1949c95f1ba929d5e71a.tar.gz
gentoo-1586fed6937a88bbe2cf1949c95f1ba929d5e71a.tar.bz2
gentoo-1586fed6937a88bbe2cf1949c95f1ba929d5e71a.zip
dev-cpp/cairomm: Update slot 0 to version 1.14.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/cairomm')
-rw-r--r--dev-cpp/cairomm/Manifest1
-rw-r--r--dev-cpp/cairomm/cairomm-1.14.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/Manifest b/dev-cpp/cairomm/Manifest
index 7067e7356e9e..3fde9e70d051 100644
--- a/dev-cpp/cairomm/Manifest
+++ b/dev-cpp/cairomm/Manifest
@@ -1,2 +1,3 @@
DIST cairomm-1.12.0.tar.xz 789588 BLAKE2B 4c864705ce4b232a3dcaf7251cf22f7f9ac2f964253552cdac5a115bc7e085f38a58375e33f99ea03105b59d056a53e91ea9234c4c6b49d8701c01c8a1e12dc2 SHA512 750e05f079c2ee9786d1a1ddb66ff90405549a82aeb542d585f904f7147994a451950a77ecb563f290cf2358f7010360ab03d9aa3a319651615c48bd25aeb7e8
+DIST cairomm-1.14.2.tar.xz 603804 BLAKE2B 37417fc13f3213c1cd51ac2b0f17e0624c0592f6115a66c96295b6fa2f9974bee7c138f5087b130211a6e4f9fba045404d85e9aa08a36d9000415132400d4da8 SHA512 aef374fca25ad22770407e36512046b266d71ebeccd47fb629cfbf2f67783aa314bb335b972088a88d98417a4774d6f144cd2769c452f8aa23770eae08dca592
DIST cairomm-1.16.0.tar.xz 579604 BLAKE2B 3aaac8039d13f13ef8fb844e38cb0cd9b0565559544c7a4cab544a46f8f8bdb6d4ee1b8318ec5d9991c33264cd3335a8796e6a49553735516a184565875e1d08 SHA512 51929620feeac45377da5d486ea7a091bbd10ad8376fb16525328947b9e6ee740cdc8e8bd190a247b457cc9fec685a829c81de29b26cabaf95383ef04cce80d3
diff --git a/dev-cpp/cairomm/cairomm-1.14.2.ebuild b/dev-cpp/cairomm/cairomm-1.14.2.ebuild
new file mode 100644
index 000000000000..79302671e416
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.14.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="https://cairographics.org/cairomm/"
+SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.6.0:2[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.0[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ -Dbuild-examples=false
+ -Dbuild-tests=$(usex test true false)
+ -Dboost-shared=true
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}