summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-30 08:04:58 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-30 08:11:05 +0200
commit01b44ee1c5ff81004e050097dfe22c98f59bc934 (patch)
treec57f98028671f6ba09865002f12ee6e9723930bf /dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild
parentwww-apps/phpsysinfo: Readd keywords from previous version (diff)
downloadgentoo-01b44ee1c5ff81004e050097dfe22c98f59bc934.tar.gz
gentoo-01b44ee1c5ff81004e050097dfe22c98f59bc934.tar.bz2
gentoo-01b44ee1c5ff81004e050097dfe22c98f59bc934.zip
dev-cpp/cpp-hocon: Add missing := ops
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild')
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..8861488d02b2
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.1.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86"
+IUSE="debug test"
+
+DEPEND="
+ >=sys-devel/gcc-4.9.3:*
+ >=dev-libs/boost-1.54:=[nls]
+ >=dev-libs/leatherman-0.9.3:=
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # make it support multilib
+ sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
+ sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}