summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-08-18 11:01:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-08-18 11:01:53 -0500
commit671687695b73fd1fb36cc45e2a40a1afacf5923c (patch)
tree7cf7601e11f49af98a2b831a277ffec446829531 /dev-cpp/cpp-hocon
parentsys-kernel/vanilla-sources: Automated version bump to {3.14.76,4.4.18,4.6.7,4... (diff)
downloadgentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.tar.gz
gentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.tar.bz2
gentoo-671687695b73fd1fb36cc45e2a40a1afacf5923c.zip
dev-cpp/cpp-hocon: adding as it's now needed by puppety things
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-cpp/cpp-hocon')
-rw-r--r--dev-cpp/cpp-hocon/Manifest1
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild44
-rw-r--r--dev-cpp/cpp-hocon/metadata.xml14
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/Manifest b/dev-cpp/cpp-hocon/Manifest
new file mode 100644
index 000000000000..c92491acbfb7
--- /dev/null
+++ b/dev-cpp/cpp-hocon/Manifest
@@ -0,0 +1 @@
+DIST cpp-hocon-0.1.2.tar.gz 150618 SHA256 28ef85d03df9413bb86ba313622d85bcc5b9fca4212bf9581c017a3ae526e874 SHA512 19081ee6d415a175bade38e5061bb06c60a1c8e886b2c395ddaa3a601b8f7928e76a6773c136387b9d5e2784dd9a0696ff183f277f32d8e636eb335d6155aadc WHIRLPOOL fb2d52a0bf7f70d3350090b85e9c25355e4c2229e5083c5830bd6b919b99406ec32bc47e6fc5a830c4e6e610cb0792234cf1cdea1b40cd70bb448abb69ba6cdd
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild
new file mode 100644
index 000000000000..60ce3d2cc5b0
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+DEPEND="
+ >=sys-devel/gcc-5.0:*
+ >=dev-libs/boost-1.57[nls]
+ dev-libs/leatherman
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # make it support multilib
+ sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
+ sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/cpp-hocon/metadata.xml b/dev-cpp/cpp-hocon/metadata.xml
new file mode 100644
index 000000000000..07ce8804cf91
--- /dev/null
+++ b/dev-cpp/cpp-hocon/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">puppetlabs/cpp-hocon</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ A C++ port of the Typesafe Config library.
+ </longdescription>
+</pkgmetadata>