summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-24 19:27:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-24 19:27:39 +0100
commita7f522cb19676c477b48a0c6a51dce9e9f45a3ed (patch)
tree9fd6d5fa1aed5fecd1c1c989aa89475ca406ea9a /dev-cpp/eigen
parentsys-fs/eudev: remove older unstable versions (diff)
downloadgentoo-a7f522cb19676c477b48a0c6a51dce9e9f45a3ed.tar.gz
gentoo-a7f522cb19676c477b48a0c6a51dce9e9f45a3ed.tar.bz2
gentoo-a7f522cb19676c477b48a0c6a51dce9e9f45a3ed.zip
dev-cpp/eigen: Forward porting ebuild changes, Backwards the patches
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=575512 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-cpp/eigen')
-rw-r--r--dev-cpp/eigen/eigen-3.2.8-r1.ebuild71
-rw-r--r--dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch (renamed from dev-cpp/eigen/files/eigen-3.2.8-adaolc-backport.patch)0
-rw-r--r--dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch (renamed from dev-cpp/eigen/files/eigen-3.2.8-pastix-5.2-backport.patch)0
3 files changed, 63 insertions, 8 deletions
diff --git a/dev-cpp/eigen/eigen-3.2.8-r1.ebuild b/dev-cpp/eigen/eigen-3.2.8-r1.ebuild
index 447ca29c55df..d79230b4ae7e 100644
--- a/dev-cpp/eigen/eigen-3.2.8-r1.ebuild
+++ b/dev-cpp/eigen/eigen-3.2.8-r1.ebuild
@@ -2,9 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit cmake-utils
+FORTRAN_NEEDED="test"
+
+inherit cmake-utils fortran-2
DESCRIPTION="C++ template library for linear algebra"
HOMEPAGE="http://eigen.tuxfamily.org/"
@@ -13,10 +15,43 @@ SRC_URI="https://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
LICENSE="LGPL-2 GPL-3"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc"
+IUSE="altivec debug doc openmp test"
+IUSE+=" cpu_flags_x86_sse2"
+IUSE+=" cpu_flags_x86_sse3"
+IUSE+=" cpu_flags_x86_sse4_1"
+IUSE+=" cpu_flags_x86_sse4_2"
+IUSE+=" cpu_flags_x86_ssse3"
+#IUSE+=" cpu_flags_x86_x87"
-DEPEND="doc? ( app-doc/doxygen[dot,latex] )"
RDEPEND="!dev-cpp/eigen:0"
+DEPEND="
+ doc? ( app-doc/doxygen[dot,latex] )
+ test? (
+ dev-libs/gmp:0
+ dev-libs/mpfr:0
+ media-libs/freeglut
+ media-libs/glew
+ sci-libs/adolc
+ sci-libs/cholmod
+ sci-libs/fftw:3.0
+ sci-libs/pastix
+ sci-libs/umfpack
+ sci-libs/scotch
+ sci-libs/spqr
+ sci-libs/superlu
+ dev-qt/qtcore:4
+ virtual/opengl
+ virtual/pkgconfig
+ )
+ "
+# Missing:
+# METIS-5
+# GOOGLEHASH
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.7-pastix-5.2-backport.patch
+ "${FILESDIR}"/${PN}-3.2.7-adaolc-backport.patch
+)
src_unpack() {
default
@@ -24,14 +59,27 @@ src_unpack() {
}
src_prepare() {
+ sed \
+ -e 's:-g2::g' \
+ -i cmake/EigenConfigureTesting.cmake || die
+
sed -i CMakeLists.txt \
-e "/add_subdirectory(demos/d" \
- -e "/add_subdirectory(blas/d" \
- -e "/add_subdirectory(lapack/d" \
|| die "sed disable unused bundles failed"
+ if ! use test; then
+ sed -i CMakeLists.txt \
+ -e "/add_subdirectory(blas/d" \
+ -e "/add_subdirectory(lapack/d" \
+ || die "sed disable unused bundles failed"
+ fi
+
sed -i -e "/Unknown build type/d" CMakeLists.txt || die
+ sed \
+ -e '/Cflags/s|:.*|: -I${CMAKE_INSTALL_PREFIX}/${INCLUDE_INSTALL_DIR}|g' \
+ -i eigen3.pc.in || die
+
cmake-utils_src_prepare
}
@@ -43,10 +91,17 @@ src_compile() {
src_test() {
local mycmakeargs=(
-DEIGEN_BUILD_TESTS=ON
- -DEIGEN_TEST_NO_FORTRAN=ON
- -DEIGEN_TEST_NO_OPENGL=ON
+ -DEIGEN_TEST_ALTIVEC="$(usex altivec)"
+ -DEIGEN_TEST_OPENMP="$(usex openmp)"
+ -DEIGEN_TEST_SSE2="$(usex cpu_flags_x86_sse2)"
+ -DEIGEN_TEST_SSE3="$(usex cpu_flags_x86_sse3)"
+ -DEIGEN_TEST_SSE4_1="$(usex cpu_flags_x86_sse4_1)"
+ -DEIGEN_TEST_SSE4_2="$(usex cpu_flags_x86_sse4_2)"
+ -DEIGEN_TEST_SSSE3="$(usex cpu_flags_x86_ssse3)"
+# -DEIGEN_TEST_X87="$(usex cpu_flags_x86_x87)"
)
cmake-utils_src_configure
+ cmake-utils_src_compile blas
cmake-utils_src_compile buildtests
cmake-utils_src_test
}
diff --git a/dev-cpp/eigen/files/eigen-3.2.8-adaolc-backport.patch b/dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch
index 82547e11951a..82547e11951a 100644
--- a/dev-cpp/eigen/files/eigen-3.2.8-adaolc-backport.patch
+++ b/dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch
diff --git a/dev-cpp/eigen/files/eigen-3.2.8-pastix-5.2-backport.patch b/dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch
index fafaf3a68629..fafaf3a68629 100644
--- a/dev-cpp/eigen/files/eigen-3.2.8-pastix-5.2-backport.patch
+++ b/dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch