summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-24 13:22:40 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-24 13:23:08 +0200
commitab37ed1117d5e094f117c5a1d8e013bacd219488 (patch)
tree21a8fe0e350facac9c60fd8e8df433619f0d26fe /dev-cpp/libjson-rpc-cpp
parentdev-cpp/libjson-rpc-cpp: Update deps & build args for live version (diff)
downloadgentoo-ab37ed1117d5e094f117c5a1d8e013bacd219488.tar.gz
gentoo-ab37ed1117d5e094f117c5a1d8e013bacd219488.tar.bz2
gentoo-ab37ed1117d5e094f117c5a1d8e013bacd219488.zip
dev-cpp/libjson-rpc-cpp: Bump to 0.6.0
Diffstat (limited to 'dev-cpp/libjson-rpc-cpp')
-rw-r--r--dev-cpp/libjson-rpc-cpp/Manifest1
-rw-r--r--dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.6.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-cpp/libjson-rpc-cpp/Manifest b/dev-cpp/libjson-rpc-cpp/Manifest
index 4a27c093b3e0..3cbe67a89e6f 100644
--- a/dev-cpp/libjson-rpc-cpp/Manifest
+++ b/dev-cpp/libjson-rpc-cpp/Manifest
@@ -1 +1,2 @@
DIST libjson-rpc-cpp-0.5.0.tar.gz 124494 SHA256 e6d8d6c20517bb38eba9dba7f372e0a95432c4cbf55ec9b136ba841faa0a6d99 SHA512 9929f76899186f62d3201d3c884a4557e3bd55acfe0533b9a0cf543e01e6d2e5972239df7425c1a43bd59fd205261b91796fdaa1ab54b55cb5765250e473d2d4 WHIRLPOOL 95b51bdfd86e63e84556c490281829d211d937cb30a503b863180cac4a2a0894eb03ed931511e9336903f1ddad6b899921e1e09663af9cc0e5739569ddc14472
+DIST libjson-rpc-cpp-0.6.0.tar.gz 130091 SHA256 98baf15e51514339be54c01296f0a51820d2d4f17f8c9d586f1747be1df3290b SHA512 8ad4e30b9ff8b53bde1671067ef6108d0a26a40d3925b2002c2aad9d66a17a51b1ea23b7ce278bcb56a992ff4c9a4616494d62dfe992c7db38341b449e88c777 WHIRLPOOL 0d6b75a29f84386086f070bb1a40e45d02f19dee567c9bd492d61aff84b470aed4d0b83879cfddb13e5109ad5d57a055f9b23b66016eb4319ed7dacd89da8474
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.6.0.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.6.0.ebuild
new file mode 100644
index 000000000000..69e35db2929b
--- /dev/null
+++ b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-0.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="JSON-RPC (1.0 & 2.0) framework for C++"
+HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
+SRC_URI="https://github.com/cinemast/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +http-client +http-server +stubgen test"
+
+RDEPEND="
+ dev-libs/jsoncpp:=
+ http-client? ( net-misc/curl:= )
+ http-server? ( net-libs/libmicrohttpd:= )
+ stubgen? ( dev-libs/argtable:= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-cpp/catch )"
+
+src_prepare() {
+ default
+
+ # https://github.com/cinemast/libjson-rpc-cpp/pull/161
+ sed -i -e '/DESTINATION/s:lib:lib${LIB_SUFFIX}:' \
+ src/jsonrpccpp/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHTTP_CLIENT=$(usex http-client)
+ -DHTTP_SERVER=$(usex http-server)
+ # they are not installed but required for tests to build
+ -DCOMPILE_EXAMPLES=$(usex test)
+ -DCOMPILE_STUBGEN=$(usex stubgen)
+ -DCOMPILE_TESTS=$(usex test)
+ -DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && emake -C "${BUILD_DIR}" doc
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r "${BUILD_DIR}"/doc/html
+}