summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/luabind
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/luabind')
-rw-r--r--dev-cpp/luabind/Manifest1
-rw-r--r--dev-cpp/luabind/files/luabind-0.9.1-boost.patch59
-rw-r--r--dev-cpp/luabind/luabind-0.9.1.ebuild58
-rw-r--r--dev-cpp/luabind/metadata.xml11
4 files changed, 129 insertions, 0 deletions
diff --git a/dev-cpp/luabind/Manifest b/dev-cpp/luabind/Manifest
new file mode 100644
index 000000000000..6c7beef4e7af
--- /dev/null
+++ b/dev-cpp/luabind/Manifest
@@ -0,0 +1 @@
+DIST luabind-0.9.1.tar.gz 194560 SHA256 80de5e04918678dd8e6dac3b22a34b3247f74bf744c719bae21faaa49649aaae SHA512 7967a27c3fccb155c282b3234e57d1943f6270988587b772a018d8d4491c8fe5418f264154405aaf1fdfaa27a3e478b026dd6c51f95d8d6092df82c468407ae1 WHIRLPOOL 6c8f0233c571ce5b91c3d44375aaf4251fd39e06f28e8ffab2207ed1b50d45a324b9c4abac944dcad501febf59972a281bc01653120ddcdf61d123db51937496
diff --git a/dev-cpp/luabind/files/luabind-0.9.1-boost.patch b/dev-cpp/luabind/files/luabind-0.9.1-boost.patch
new file mode 100644
index 000000000000..92e32828a03c
--- /dev/null
+++ b/dev-cpp/luabind/files/luabind-0.9.1-boost.patch
@@ -0,0 +1,59 @@
+diff --git luabind-0.9.1/luabind/detail/call_function.hpp luabind-0.9.1-fixed/luabind/detail/call_function.hpp
+index 1b45ec1..8f5afff 100644
+--- luabind-0.9.1/luabind/detail/call_function.hpp
++++ luabind-0.9.1-fixed/luabind/detail/call_function.hpp
+@@ -323,7 +323,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_FUNCTION_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -440,4 +441,5 @@ namespace luabind
+
+
+ #endif
++#endif
+
+diff --git luabind-0.9.1/luabind/detail/call_member.hpp luabind-0.9.1-fixed/luabind/detail/call_member.hpp
+index de8d563..e63555b 100644
+--- luabind-0.9.1/luabind/detail/call_member.hpp
++++ luabind-0.9.1-fixed/luabind/detail/call_member.hpp
+@@ -316,7 +316,8 @@ namespace luabind
+
+ #endif // LUABIND_CALL_MEMBER_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -360,4 +361,5 @@ namespace luabind
+ #undef LUABIND_TUPLE_PARAMS
+
+ #endif
++#endif
+
+diff --git luabind-0.9.1/luabind/wrapper_base.hpp luabind-0.9.1-fixed/luabind/wrapper_base.hpp
+index d54c668..0f88cc5 100755
+--- luabind-0.9.1/luabind/wrapper_base.hpp
++++ luabind-0.9.1-fixed/luabind/wrapper_base.hpp
+@@ -89,7 +89,8 @@ namespace luabind
+
+ #endif // LUABIND_WRAPPER_BASE_HPP_INCLUDED
+
+-#elif BOOST_PP_ITERATION_FLAGS() == 1
++#else
++#if BOOST_PP_ITERATION_FLAGS() == 1
+
+ #define LUABIND_TUPLE_PARAMS(z, n, data) const A##n *
+ #define LUABIND_OPERATOR_PARAMS(z, n, data) const A##n & a##n
+@@ -188,3 +189,4 @@ namespace luabind
+ #undef N
+
+ #endif
++#endif
diff --git a/dev-cpp/luabind/luabind-0.9.1.ebuild b/dev-cpp/luabind/luabind-0.9.1.ebuild
new file mode 100644
index 000000000000..c88e27363d37
--- /dev/null
+++ b/dev-cpp/luabind/luabind-0.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# NOTE: cross compiling is probably broken
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Creates bindings for lua on c++"
+HOMEPAGE="http://www.rasterbar.com/products/luabind.html"
+SRC_URI="mirror://sourceforge/luabind/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/boost-build"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-boost.patch
+
+ # backwardscomapt with old boost-build-1.49.0
+ if [[ -e $(which bjam-1_49 2>/dev/null) ]] ; then
+ my_bjam_bin=bjam-1_49
+ else
+ my_bjam_bin=bjam
+ fi
+}
+
+src_compile() {
+ # linkflags get appended, so they actually do nothing
+ ${my_bjam_bin} release \
+ -d+2 \
+ --prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ cflags="${CFLAGS}" \
+ linkflags="${LDFLAGS}" \
+ link=shared || die "compile failed"
+}
+
+src_install() {
+ ${my_bjam_bin} release \
+ -d+2 \
+ --prefix="${D}/usr/" \
+ --libdir="${D}/usr/$(get_libdir)" \
+ cflags="${CFLAGS}" \
+ linkflags="${LDFLAGS}" \
+ link=shared \
+ install || die "install failed"
+}
+
+# generally, this really sucks, patches welcome
diff --git a/dev-cpp/luabind/metadata.xml b/dev-cpp/luabind/metadata.xml
new file mode 100644
index 000000000000..0036cf5d2d97
--- /dev/null
+++ b/dev-cpp/luabind/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">luabind</remote-id>
+ </upstream>
+</pkgmetadata>