summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/pngpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/pngpp')
-rw-r--r--dev-cpp/pngpp/Manifest1
-rw-r--r--dev-cpp/pngpp/metadata.xml6
-rw-r--r--dev-cpp/pngpp/pngpp-0.2.5.ebuild31
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/pngpp/Manifest b/dev-cpp/pngpp/Manifest
new file mode 100644
index 000000000000..09a2099d16cf
--- /dev/null
+++ b/dev-cpp/pngpp/Manifest
@@ -0,0 +1 @@
+DIST png++-0.2.5.tar.gz 577854 SHA256 339fa2dff2cdd117efb43768cb272745faef4d02705b5e0e840537a2c1467b72 SHA512 df1cc5eab06bc15ab180ef7c53a0237bbf9fabccfb04105c92eda0b40f8b181466a386a3abd52f0b733a995414384c99df2d85c7bf211831c838f97b798d4183 WHIRLPOOL 13264b9b51f9850fde3200d7d92834bd7fef2a0d9282ea2dc999b0bc2a1988de1fc10a544a7533f970ee1760b8091e8195b1d5bdecb4388311606e18fea91f9f
diff --git a/dev-cpp/pngpp/metadata.xml b/dev-cpp/pngpp/metadata.xml
new file mode 100644
index 000000000000..7ad27a2ced99
--- /dev/null
+++ b/dev-cpp/pngpp/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<herd>cpp</herd>
+</pkgmetadata>
diff --git a/dev-cpp/pngpp/pngpp-0.2.5.ebuild b/dev-cpp/pngpp/pngpp-0.2.5.ebuild
new file mode 100644
index 000000000000..593bcc9009fa
--- /dev/null
+++ b/dev-cpp/pngpp/pngpp-0.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=${P/pp/++}
+
+DESCRIPTION="A simple but powerful C++ interface to libpng"
+HOMEPAGE="http://www.nongnu.org/pngpp/"
+SRC_URI="mirror://nongnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libpng-1.2:0"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ emake PREFIX="${D}/usr" install-headers
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ docinto examples
+ dodoc example/*.cpp
+}